summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:23:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:44:37 -0500
commitb16cc962ece1e2f07ec96bd501a90ca531efb7cc (patch)
treea88b3c913422e058da251ba855846b905e85cfd3 /dev-python/os-brick/os-brick-2.5.5.ebuild
parentdev-python/oslo-cache: 1.30.3 bump (diff)
downloadgentoo-b16cc962ece1e2f07ec96bd501a90ca531efb7cc.tar.gz
gentoo-b16cc962ece1e2f07ec96bd501a90ca531efb7cc.tar.bz2
gentoo-b16cc962ece1e2f07ec96bd501a90ca531efb7cc.zip
dev-python/os-brick: 2.5.5 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/os-brick/os-brick-2.5.5.ebuild')
-rw-r--r--dev-python/os-brick/os-brick-2.5.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/os-brick/os-brick-2.5.5.ebuild b/dev-python/os-brick/os-brick-2.5.5.ebuild
new file mode 100644
index 000000000000..0229d3350c19
--- /dev/null
+++ b/dev-python/os-brick/os-brick-2.5.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/cinder"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-win-3.0.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}