summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 23:35:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:08:07 -0500
commit90a8930d4f7aa3c32a31936909d9d8a7d39fff6d (patch)
tree9eaf156f9520cded3f45e57aa9b269724643a801 /dev-python/os-brick/os-brick-2.8.1.ebuild
parentdev-python/retrying: add py37 support (diff)
downloadgentoo-90a8930d4f7aa3c32a31936909d9d8a7d39fff6d.tar.gz
gentoo-90a8930d4f7aa3c32a31936909d9d8a7d39fff6d.tar.bz2
gentoo-90a8930d4f7aa3c32a31936909d9d8a7d39fff6d.zip
dev-python/os-brick: 2.8.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/os-brick/os-brick-2.8.1.ebuild')
-rw-r--r--dev-python/os-brick/os-brick-2.8.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/os-brick/os-brick-2.8.1.ebuild b/dev-python/os-brick/os-brick-2.8.1.ebuild
new file mode 100644
index 000000000000..51c48d82f50a
--- /dev/null
+++ b/dev-python/os-brick/os-brick-2.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
+HOMEPAGE="https://github.com/openstack/cinder"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.24.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-service-1.28.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-win-3.0.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}