summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-04-25 13:41:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-25 13:41:32 -0500
commit617c54030bb49bdefca2237d90aa259cb9a4e04f (patch)
treecf1a02b6339dde61755a70f674d70c33b67420f3 /dev-python/os-brick
parentgames-action/extreme-tuxracer: bump up to 0.8.0 (diff)
downloadgentoo-617c54030bb49bdefca2237d90aa259cb9a4e04f.tar.gz
gentoo-617c54030bb49bdefca2237d90aa259cb9a4e04f.tar.bz2
gentoo-617c54030bb49bdefca2237d90aa259cb9a4e04f.zip
dev-python/os-brick: fix installing to /usr/etc
Closes: https://bugs.gentoo.org/785472 Package-Manager: Portage-3.0.18, Repoman-3.0.2 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/os-brick')
-rw-r--r--dev-python/os-brick/os-brick-4.0.1-r1.ebuild (renamed from dev-python/os-brick/os-brick-4.0.1.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/os-brick/os-brick-4.0.1.ebuild b/dev-python/os-brick/os-brick-4.0.1-r1.ebuild
index 12b80504c96a..dfc56644fd22 100644
--- a/dev-python/os-brick/os-brick-4.0.1.ebuild
+++ b/dev-python/os-brick/os-brick-4.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -32,3 +32,8 @@ RDEPEND="
>=dev-python/tenacity-6.0.0[${PYTHON_USEDEP}]
>=dev-python/os-win-3.0.0[${PYTHON_USEDEP}]
"
+
+python_prepare_all() {
+ sed -i -e 's/\tetc/\t\/etc/g' setup.cfg || die
+ distutils-r1_python_prepare_all
+}