summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-24 18:28:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-24 19:08:51 +0100
commit8d210c1f4c19cbd361e719d31fad45b378c4cd23 (patch)
treebe8e9f13aca22fccc4b7c885c612a500dae300ab /dev-python/os-service-types
parentdev-python/tempest: PEP517, py3.10 (diff)
downloadgentoo-8d210c1f4c19cbd361e719d31fad45b378c4cd23.tar.gz
gentoo-8d210c1f4c19cbd361e719d31fad45b378c4cd23.tar.bz2
gentoo-8d210c1f4c19cbd361e719d31fad45b378c4cd23.zip
dev-python/os-service-types: PEP517, py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/os-service-types')
-rw-r--r--dev-python/os-service-types/os-service-types-1.7.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/os-service-types/os-service-types-1.7.0-r2.ebuild b/dev-python/os-service-types/os-service-types-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..d8de2d912307
--- /dev/null
+++ b/dev-python/os-service-types/os-service-types-1.7.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to handle official service types for OpenStack and it's aliases"
+HOMEPAGE="https://github.com/openstack/os-service-types"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest