summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-30 15:54:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-30 16:06:40 -0500
commitb40eee97dd3e89202987a96d78cea6061027849d (patch)
treef2f6ad2f614bfe2da857969dc2b5fdd8b71d5497 /dev-python/os-traits
parentdev-python/os-vif: 1.7.0 bup (diff)
downloadgentoo-b40eee97dd3e89202987a96d78cea6061027849d.tar.gz
gentoo-b40eee97dd3e89202987a96d78cea6061027849d.tar.bz2
gentoo-b40eee97dd3e89202987a96d78cea6061027849d.zip
dev-python/os-traits: adding for pike
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/os-traits')
-rw-r--r--dev-python/os-traits/Manifest1
-rw-r--r--dev-python/os-traits/metadata.xml14
-rw-r--r--dev-python/os-traits/os-traits-0.3.3.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/os-traits/Manifest b/dev-python/os-traits/Manifest
new file mode 100644
index 000000000000..16c59b9e75fc
--- /dev/null
+++ b/dev-python/os-traits/Manifest
@@ -0,0 +1 @@
+DIST os-traits-0.3.3.tar.gz 17374 SHA256 130da3936873ded6d607e2cca85c12d603ad0971ace9d8c72fbf7fea67027edf SHA512 bd8a7a29170aee1be59ed21684ed2a5dbb1440841a54b522bd3ec31ef61c9fd4f6eecca812c8a8b927c285142801c3da190d7bb47c7b315312e10c1c81d50e27 WHIRLPOOL 31cbb9a40350d259988269ee9d80c8da826ac02a2d119dd514d7258a284963b5ee505969e04c2b3af41b737f79cd3edf53cdfbbdd563474b2ad39ccccfe3015c
diff --git a/dev-python/os-traits/metadata.xml b/dev-python/os-traits/metadata.xml
new file mode 100644
index 000000000000..8c623aa52d56
--- /dev/null
+++ b/dev-python/os-traits/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">openstack/os-traits</remote-id>
+ <remote-id type="pypi">os-traits</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/os-traits/os-traits-0.3.3.ebuild b/dev-python/os-traits/os-traits-0.3.3.ebuild
new file mode 100644
index 000000000000..52e4b51e566b
--- /dev/null
+++ b/dev-python/os-traits/os-traits-0.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}