summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 23:21:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:08:01 -0500
commit3cfe4d5a5b6b9d699ddc87865534e08c7e970a37 (patch)
treebea7fbac567abaf6d4a9d255d2e53be3f07239c8 /dev-python/os-win/os-win-4.2.0.ebuild
parentdev-python/cursive: 0.2.2 bump (diff)
downloadgentoo-3cfe4d5a5b6b9d699ddc87865534e08c7e970a37.tar.gz
gentoo-3cfe4d5a5b6b9d699ddc87865534e08c7e970a37.tar.bz2
gentoo-3cfe4d5a5b6b9d699ddc87865534e08c7e970a37.zip
dev-python/os-win: 4.2.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/os-win/os-win-4.2.0.ebuild')
-rw-r--r--dev-python/os-win/os-win-4.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/os-win/os-win-4.2.0.ebuild b/dev-python/os-win/os-win-4.2.0.ebuild
new file mode 100644
index 000000000000..307b261b74d6
--- /dev/null
+++ b/dev-python/os-win/os-win-4.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ sed -i '/win32/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}