summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 14:17:48 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 14:43:50 -0500
commitbe9a38b1a06b1cf853d5b703f1cb60accd8009ef (patch)
tree04e10ce9b0bfafd68471f896af172a37d2c6a219 /dev-python/os-xenapi/os-xenapi-0.3.4.ebuild
parentdev-python/os-ken: initial add for neutron (diff)
downloadgentoo-be9a38b1a06b1cf853d5b703f1cb60accd8009ef.tar.gz
gentoo-be9a38b1a06b1cf853d5b703f1cb60accd8009ef.tar.bz2
gentoo-be9a38b1a06b1cf853d5b703f1cb60accd8009ef.zip
dev-python/os-xenapi: 0.3.4 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/os-xenapi/os-xenapi-0.3.4.ebuild')
-rw-r--r--dev-python/os-xenapi/os-xenapi-0.3.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/os-xenapi/os-xenapi-0.3.4.ebuild b/dev-python/os-xenapi/os-xenapi-0.3.4.ebuild
new file mode 100644
index 000000000000..193e84a1a6f7
--- /dev/null
+++ b/dev-python/os-xenapi/os-xenapi-0.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="XenAPI library for OpenStack projects"
+HOMEPAGE="https://github.com/openstack/os-xenapi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}