summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-07-02 18:41:08 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-07-02 18:54:07 -0500
commit4083dd00039b500e0f23ba981f7c9566b5159d8a (patch)
tree0cec47eabad9df5d429312dbf9aa1ee8ac0f0981 /dev-python/oslo-cache/oslo-cache-1.33.3.ebuild
parentdev-python/oslo-serialization: 3.1.1 stable amd64/x86 with cleanup (diff)
downloadgentoo-4083dd00039b500e0f23ba981f7c9566b5159d8a.tar.gz
gentoo-4083dd00039b500e0f23ba981f7c9566b5159d8a.tar.bz2
gentoo-4083dd00039b500e0f23ba981f7c9566b5159d8a.zip
dev-python/oslo-cache: 2.3.0 stable amd64/x86
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-cache/oslo-cache-1.33.3.ebuild')
-rw-r--r--dev-python/oslo-cache/oslo-cache-1.33.3.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/oslo-cache/oslo-cache-1.33.3.ebuild b/dev-python/oslo-cache/oslo-cache-1.33.3.ebuild
deleted file mode 100644
index e0d9e2955bfe..000000000000
--- a/dev-python/oslo-cache/oslo-cache-1.33.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Caching around dogpile.cache"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
-)
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}