summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-30 16:09:38 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-30 16:09:55 -0500
commitf3a1dbe7b6577acbcee544524d51b96b1768d3eb (patch)
tree9acaf8d1849f1a7d739e6637cae68af6b2a7cef6 /dev-python/oslo-concurrency/oslo-concurrency-4.3.1.ebuild
parentnet-misc/croc: bump to 8.6.5 (diff)
downloadgentoo-f3a1dbe7b6577acbcee544524d51b96b1768d3eb.tar.gz
gentoo-f3a1dbe7b6577acbcee544524d51b96b1768d3eb.tar.bz2
gentoo-f3a1dbe7b6577acbcee544524d51b96b1768d3eb.zip
dev-python/oslo-concurrency: 4.3.1 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-concurrency/oslo-concurrency-4.3.1.ebuild')
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.3.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.3.1.ebuild
new file mode 100644
index 000000000000..3a0f219accf1
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="library for running multi-thread, multi-process applications"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
+S="${WORKDIR}/oslo.concurrency-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+RESTRICT=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"