summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-03 18:23:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-03 18:23:22 -0500
commita24b40aad81e5d5a01d463ad5d6dd638f71c807b (patch)
treefd1194ab9412aaca020a8ad06ded2f91becb326d /dev-python/oslo-config/oslo-config-6.8.1.ebuild
parentapp-crypt/certbot-nginx: 0.38.0 stable amd64/x86 with cleanup (diff)
downloadgentoo-a24b40aad81e5d5a01d463ad5d6dd638f71c807b.tar.gz
gentoo-a24b40aad81e5d5a01d463ad5d6dd638f71c807b.tar.bz2
gentoo-a24b40aad81e5d5a01d463ad5d6dd638f71c807b.zip
dev-python/oslo-config: remove broken doc build
fixes: https://bugs.gentoo.org/696104 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-config/oslo-config-6.8.1.ebuild')
-rw-r--r--dev-python/oslo-config/oslo-config-6.8.1.ebuild15
1 files changed, 1 insertions, 14 deletions
diff --git a/dev-python/oslo-config/oslo-config-6.8.1.ebuild b/dev-python/oslo-config/oslo-config-6.8.1.ebuild
index 4ecd74de591c..abb7cf055eeb 100644
--- a/dev-python/oslo-config/oslo-config-6.8.1.ebuild
+++ b/dev-python/oslo-config/oslo-config-6.8.1.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+IUSE="test"
CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
DEPEND="
@@ -36,12 +36,6 @@ DEPEND="
>=dev-python/requests-mock-1.5.0[${PYTHON_USEDEP}]
>=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
)
- doc? (
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- )
"
RDEPEND="
${CDEPEND}
@@ -58,7 +52,6 @@ RDEPEND="
python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
- use doc && esetup.py build_sphinx
distutils-r1_python_prepare_all
}
@@ -68,9 +61,3 @@ python_test() {
testr init || die "testr init failed under ${EPYTHON}"
testr run || die "testr run failed under ${EPYTHON}"
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}