summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-10 19:58:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-10 20:29:15 -0500
commit11817667fbe76a3be2d8f95836fb2b151d8123b0 (patch)
tree02869598419477d97b8f521e2405c53b440bf076 /dev-python/oslo-context
parentdev-python/oslo-utils: 4.6.0 bump (diff)
downloadgentoo-11817667fbe76a3be2d8f95836fb2b151d8123b0.tar.gz
gentoo-11817667fbe76a3be2d8f95836fb2b151d8123b0.tar.bz2
gentoo-11817667fbe76a3be2d8f95836fb2b151d8123b0.zip
dev-python/oslo-context: 3.1.1 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-context')
-rw-r--r--dev-python/oslo-context/Manifest1
-rw-r--r--dev-python/oslo-context/oslo-context-3.1.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/oslo-context/Manifest b/dev-python/oslo-context/Manifest
index 38d82ebd550d..20a319c097cf 100644
--- a/dev-python/oslo-context/Manifest
+++ b/dev-python/oslo-context/Manifest
@@ -1 +1,2 @@
DIST oslo.context-2.22.1.tar.gz 29315 BLAKE2B 89c7dacfe42a9c3cd8d7fde8a77e3654f48788909cea725151e833a305c6916534919496393e603084311625cc9242661e72cbf1a2bdb72bedca3127e77ca9d9 SHA512 d0a3b9e41d23e8f642f8aacd998f6d6f4ad1fbf103947fc7403a57c4e3d9ae51b3cf73dfb79139d541875a0e412ed8600c4ce6b19cc207697429f48a7fb72887
+DIST oslo.context-3.1.1.tar.gz 29335 BLAKE2B 2179e5c273b5e387806fc4a8b1ac2f0641f4cc9f2345cb00e6ef9c2e7c8b69709c0c14dd11254d026283b2be7e032044b6f753a13f062915db9f000ae1873f1a SHA512 a9d16475bac5aa96d086019632f417fa5b496f615b814527e547a43362f1e36ed47c47266032e72194f88716237ccff7a24bf941d66bf36afe09b846a810583b
diff --git a/dev-python/oslo-context/oslo-context-3.1.1.ebuild b/dev-python/oslo-context/oslo-context-3.1.1.ebuild
new file mode 100644
index 000000000000..0bed5501a70f
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-3.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.org/project/oslo.context/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+S="${WORKDIR}/oslo.context-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]"