summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-11 12:27:16 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-11 13:05:55 -0600
commit4372c38b9f5d15adf6ec25e4f9418c8fe025d965 (patch)
treece79dd6bfea82cba1afc8da805205d77e6a662df /dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
parentdev-python/oslo-db: cleanup (diff)
downloadgentoo-4372c38b9f5d15adf6ec25e4f9418c8fe025d965.tar.gz
gentoo-4372c38b9f5d15adf6ec25e4f9418c8fe025d965.tar.bz2
gentoo-4372c38b9f5d15adf6ec25e4f9418c8fe025d965.zip
dev-python/oslo-i18n: cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild')
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
deleted file mode 100644
index 1bd39e3d2bdc..000000000000
--- a/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo i18n library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}