summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 21:00:42 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:24:35 -0500
commit32fff667f13044e9f7e9b2ed403f4f3ae874cc3b (patch)
tree3177c1c5e505fa726b293bad2a71bb7211cd5753 /dev-python/oslo-policy/oslo-policy-1.25.1.ebuild
parentdev-python/oslo-serialization: 2.20.0 bup (diff)
downloadgentoo-32fff667f13044e9f7e9b2ed403f4f3ae874cc3b.tar.gz
gentoo-32fff667f13044e9f7e9b2ed403f4f3ae874cc3b.tar.bz2
gentoo-32fff667f13044e9f7e9b2ed403f4f3ae874cc3b.zip
dev-python/oslo-policy: 1.25.1 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/oslo-policy/oslo-policy-1.25.1.ebuild')
-rw-r--r--dev-python/oslo-policy/oslo-policy-1.25.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/oslo-policy/oslo-policy-1.25.1.ebuild b/dev-python/oslo-policy/oslo-policy-1.25.1.ebuild
new file mode 100644
index 000000000000..cee01226d294
--- /dev/null
+++ b/dev-python/oslo-policy/oslo-policy-1.25.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support for RBAC policy enforcement across all OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.policy"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.policy/oslo.policy-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.policy-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}