summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 00:06:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:57 -0500
commit9b0d9da4e1664cbdfcd45e3c1d2e947bea55e8ea (patch)
tree3c2d2d9509cfb83bec7e0bf6cb46748b4a8ebbb6 /dev-python/oslo-policy/oslo-policy-2.1.1.ebuild
parentdev-python/oslo-context: 2.28.1 bump (diff)
downloadgentoo-9b0d9da4e1664cbdfcd45e3c1d2e947bea55e8ea.tar.gz
gentoo-9b0d9da4e1664cbdfcd45e3c1d2e947bea55e8ea.tar.bz2
gentoo-9b0d9da4e1664cbdfcd45e3c1d2e947bea55e8ea.zip
dev-python/oslo-policy: 2.1.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-policy/oslo-policy-2.1.1.ebuild')
-rw-r--r--dev-python/oslo-policy/oslo-policy-2.1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/oslo-policy/oslo-policy-2.1.1.ebuild b/dev-python/oslo-policy/oslo-policy-2.1.1.ebuild
new file mode 100644
index 000000000000..e332b152dd1c
--- /dev/null
+++ b/dev-python/oslo-policy/oslo-policy-2.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Support for RBAC policy enforcement across all OpenStack services"
+HOMEPAGE="https://pypi.org/project/oslo.policy/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.policy/oslo.policy-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.policy-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}