summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:41:32 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:48:13 -0500
commite2fb6e5d7f154deabe7e62a141cc7a1239a72232 (patch)
treeb4878a041bf77518d284ed9c4e05c3beb864c90d /dev-python/oslo-rootwrap
parentdev-python/os-brick: 4.0.1 bump (diff)
downloadgentoo-e2fb6e5d7f154deabe7e62a141cc7a1239a72232.tar.gz
gentoo-e2fb6e5d7f154deabe7e62a141cc7a1239a72232.tar.bz2
gentoo-e2fb6e5d7f154deabe7e62a141cc7a1239a72232.zip
dev-python/oslo-rootwrap: 6.2.0 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-rootwrap')
-rw-r--r--dev-python/oslo-rootwrap/Manifest1
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-6.2.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
index 455052201511..9eb1e5cd74a1 100644
--- a/dev-python/oslo-rootwrap/Manifest
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -1 +1,2 @@
DIST oslo.rootwrap-5.15.2.tar.gz 45566 BLAKE2B 1755a52d1e380a512c50f5314f7a4f249da9e62030abfef531bf973277a98f1f42f1c27a69a4e6e5cf64441e6a7263a3780355da4860461cfafed172ea087946 SHA512 9fc4c4678a25ebecb08026e71ef8da44bf1214f177d5330de8d68cfce8c3d85f4085a9e19f282bc8b498a36d8a7e384cde354a95619a800e3a68aba088df5aad
+DIST oslo.rootwrap-6.2.0.tar.gz 46850 BLAKE2B 0ad998aecaf8dfe0616094ed08e64380d38fa663dc63f192b58b95a07deeb690f16f1b8de2d0666c80bc49c11c06dc7221e9b9fae7243c3569971745884b752f SHA512 bf3e91ec8a18f92f6f5974a6d8369ae73dba6e61fa3001996678b85d0bfb2426536d27097ad784169e6eca50ad23471505d5089e8d4a6a84c9e0e009a6a38f5a
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-6.2.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-6.2.0.ebuild
new file mode 100644
index 000000000000..1c245594add7
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-6.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.org/project/oslo.config/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"