summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-06-17 20:58:00 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-06-17 20:59:30 -0500
commite75b9cd0cc9b8bf593e37813f7a647afee17a897 (patch)
treeec150968317eb1b6a10d824a499883cb9598f050 /dev-python/oslotest
parentdev-python/oslo-sphinx: cleanup (diff)
downloadgentoo-e75b9cd0cc9b8bf593e37813f7a647afee17a897.tar.gz
gentoo-e75b9cd0cc9b8bf593e37813f7a647afee17a897.tar.bz2
gentoo-e75b9cd0cc9b8bf593e37813f7a647afee17a897.zip
dev-python/oslotest: cleanup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/Manifest1
-rw-r--r--dev-python/oslotest/oslotest-2.17.1.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/oslotest/Manifest b/dev-python/oslotest/Manifest
index 19b6d49bb9cb..159f93d5c684 100644
--- a/dev-python/oslotest/Manifest
+++ b/dev-python/oslotest/Manifest
@@ -1,2 +1 @@
-DIST oslotest-2.17.1.tar.gz 32166 BLAKE2B 49922cedc32bebda867c6633118cbd8258a08048c510333d04e0b2f8f5efd4e5dde802bfb8910936dffca76823771d3e83e78528b5fd045ae4380e02f92cf809 SHA512 558d2c220a6b1235112022b495c77881f52895cb720d67090ad096576b4e81044b228bd95b8303779bf8cca2e1205ef912b1fedd1916a34130f4c68ef69fcc0d
DIST oslotest-3.2.0.tar.gz 35445 BLAKE2B d33c70e760fc595586c2d7b0ce6ed1f63b73c89ba078f85b70d3b6b1af1c4d115e6eb7b431f9ef52abf50290eb47a1d3adb2d014c2ba5cf7b93ecf0e46401a26 SHA512 4513291e2bec939f9734255cb0fe3f85b9eb8a8cadce58873ad4e85365a0ec27bc2084085f5b95b681b5e811b62458e18fe63aff1e022b2d8ace0ca48bd6a527
diff --git a/dev-python/oslotest/oslotest-2.17.1.ebuild b/dev-python/oslotest/oslotest-2.17.1.ebuild
deleted file mode 100644
index 63000aeac9ce..000000000000
--- a/dev-python/oslotest/oslotest-2.17.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Oslo test framework"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/oslo-config-4.0.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-config-4.3.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-config-4.4.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0[${PYTHON_USEDEP}]
- >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
- !~dev-python/mox3-0.19.0[${PYTHON_USEDEP}]
- >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx -b man
- fi
-}
-
-python_test() {
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- doman doc/build/man/oslotest.1
- fi
-
- distutils-r1_python_install_all
-}