summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-13 13:31:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-13 13:31:22 +0200
commit1a9cbe70923930098b98c3b5450561948f4705d8 (patch)
tree68e78095620612007541e7593934807c26603ff5 /dev-python/osrf_pycommon/osrf_pycommon-0.1.10-r1.ebuild
parentdev-python/rospkg: set proper distutils dep; add py39 (diff)
downloadgentoo-1a9cbe70923930098b98c3b5450561948f4705d8.tar.gz
gentoo-1a9cbe70923930098b98c3b5450561948f4705d8.tar.bz2
gentoo-1a9cbe70923930098b98c3b5450561948f4705d8.zip
dev-python/osrf_pycommon: proper distutils dep; add py39
Closes: https://bugs.gentoo.org/748417 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/osrf_pycommon/osrf_pycommon-0.1.10-r1.ebuild')
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-0.1.10-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-0.1.10-r1.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10-r1.ebuild
new file mode 100644
index 000000000000..9f8238dc18f6
--- /dev/null
+++ b/dev-python/osrf_pycommon/osrf_pycommon-0.1.10-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Commonly needed Python modules used by Python software developed at OSRF"
+HOMEPAGE="https://github.com/osrf/osrf_pycommon"
+SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/mock[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/str.patch" )
+
+distutils_enable_tests pytest