summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-09 08:06:54 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-09 08:32:31 +0200
commit7df738761c1cfa16e62eb2f3d1b581a9b72d8ede (patch)
treead8445b6f81e350e699d7427ee5ca5e21d2681dc /dev-python/osrf_pycommon
parentdev-python/blurb: Bump to 1.1.0 (diff)
downloadgentoo-7df738761c1cfa16e62eb2f3d1b581a9b72d8ede.tar.gz
gentoo-7df738761c1cfa16e62eb2f3d1b581a9b72d8ede.tar.bz2
gentoo-7df738761c1cfa16e62eb2f3d1b581a9b72d8ede.zip
dev-python/osrf_pycommon: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/osrf_pycommon')
-rw-r--r--dev-python/osrf_pycommon/Manifest1
-rw-r--r--dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/osrf_pycommon/Manifest b/dev-python/osrf_pycommon/Manifest
index 34446f944791..fc3c829b511b 100644
--- a/dev-python/osrf_pycommon/Manifest
+++ b/dev-python/osrf_pycommon/Manifest
@@ -1,3 +1,4 @@
DIST osrf_pycommon-1.0.0.tar.gz 45084 BLAKE2B 83bfd5393575a5032e72ae93c9c3eec87d2907ce3fbd3e9fe14a94e5470d61594ab75bca394ec4b7960bbdb16c3ec060966bd6bf47f9a4037d530501c7ce947f SHA512 ff7204116c94eef972b7071f8d6c68fd7cdb1a518fd6c77cd47f54e5390815ff4b6a7d265ef3ed0093c1baa20eb332d69e92926e856da0e34b7186100b688d83
DIST osrf_pycommon-2.0.0.tar.gz 45467 BLAKE2B bcf111183b66dd19e24182e6fee75674f0481bdeb2498ea2a0d10c56977651da60f94444706df525ee71f64d5eb1a24e2e5b4acaf13f19f94b787ce5b424c81e SHA512 ebb06a86c3527ea9dfb24778410a7f84d5560216aedd4ed5fe0b22660b6fbf9625d093dc8653db58a2cc7f3a81e6c4a2770fca90694441cdb141fb840935c50e
DIST osrf_pycommon-2.0.1.tar.gz 45839 BLAKE2B 9961eade38c8de980cee01debbc177ae8ef3ef872d2525c9c6a1660e2323a5bfc02d9f5e6295aeada0cb3a9506da27637eb3c042a1328aff7b5e0e6435bd4dc4 SHA512 9f8affe81c6adc7436ccf9481a84b98a32650c6a0d6bff9c378faf1a9202bfeccb9f72046fecdcdd38f5d6047319db97e6e7e090446ab2fce759949046590f4b
+DIST osrf_pycommon-2.0.2.tar.gz 45927 BLAKE2B 49d8ada07d5cae3b9ad0fac7bae38749517680d3c7d7b84f06f83e4f6d14534cd62fdc72bf4fe11faf0eac4d7e5ef133b9a2410e689fafdaadbb5c1a7838a371 SHA512 3efba5e7010bf96e264c01bad1f095e121e998f34125b6393e5154eb7632704ae18e5d72f17862f527d584bd2e2e216d115b8c87e523ddcfff6656d6db331091
diff --git a/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild b/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
new file mode 100644
index 000000000000..b096ab70236b
--- /dev/null
+++ b/dev-python/osrf_pycommon/osrf_pycommon-2.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Commonly needed Python modules used by Python software developed at OSRF"
+HOMEPAGE="https://github.com/osrf/osrf_pycommon"
+SRC_URI="https://github.com/osrf/osrf_pycommon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # linting is something upstreams do
+ # for us, it either means unneeded deps or breakage due to changes
+ tests/test_code_format.py
+)