summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-11 21:44:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-11 21:44:11 +0300
commit8289ed0d0ad51a5563f0b87dc709f250316f3128 (patch)
tree6f6400e87616ca2d62869650d7d129ff0b01727a /dev-python/owslib
parentdev-python/xmlschema: add 1.11.2 (diff)
downloadgentoo-8289ed0d0ad51a5563f0b87dc709f250316f3128.tar.gz
gentoo-8289ed0d0ad51a5563f0b87dc709f250316f3128.tar.bz2
gentoo-8289ed0d0ad51a5563f0b87dc709f250316f3128.zip
dev-python/owslib: add 0.26.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/owslib')
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/owslib-0.26.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index 7ddc8b754659..6879e266c9ae 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1 +1,2 @@
DIST owslib-0.25.0.tar.gz 936550 BLAKE2B 9cb34a6c7c93dc89a466c13351d457c9372d405055fa3f6cec9c05c231e76762168c6813085523037b3a6439100500c46c1044569bd2bb598c3e2e63757d8b86 SHA512 058108cf77197ce24793608869d56bf0467230f5f231ac9ba48445f2e02d07ea1e26be03ad6967504a1e625008ae2768ed2a663f3b7a49dcea410ee4a8b40cec
+DIST owslib-0.26.0.gh.tar.gz 948463 BLAKE2B 2cbdad2d8e9bc4b8a7e2db58dc75a7c053bde0b2cc772a01f230db044909615b96e62b08bb93233df153686a180a5e93af1bda6ea79b8565efacccfa18fcf4da SHA512 27362c47eae87dc6318d505dd1b0987de36d140d2d0fd5d7a5195470de39d73807fbcafa142366f6981cc36453c262a41133c6c68baf45a97d0fdaae5a0ebf4b
diff --git a/dev-python/owslib/owslib-0.26.0.ebuild b/dev-python/owslib/owslib-0.26.0.ebuild
new file mode 100644
index 000000000000..50d119522978
--- /dev/null
+++ b/dev-python/owslib/owslib-0.26.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="https://geopython.github.io/OWSLib/"
+SRC_URI="
+ https://github.com/geopython/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/OWSLib-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/pillow[${PYTHON_USEDEP}] )"
+
+EPYTEST_DESELECT=(
+ tests/test_ogcapi_features_pygeoapi.py::test_ogcapi_features_pygeoapi
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i tox.ini || die
+ distutils-r1_src_prepare
+}