summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-01 20:48:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-01 21:16:54 +0100
commitec45c461f7aafd6d3e3fa1693c76d53e1218eb08 (patch)
tree43a0ce5e33fa73d5afb90f45f530d31df99e6949 /dev-python/owslib
parentdev-python/pyproj: Drop unnecessary python_gen_cond_dep (diff)
downloadgentoo-ec45c461f7aafd6d3e3fa1693c76d53e1218eb08.tar.gz
gentoo-ec45c461f7aafd6d3e3fa1693c76d53e1218eb08.tar.bz2
gentoo-ec45c461f7aafd6d3e3fa1693c76d53e1218eb08.zip
dev-python/owslib: python3_7
Package-Manager: Portage-2.3.80, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/owslib')
-rw-r--r--dev-python/owslib/owslib-0.17.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/owslib/owslib-0.17.1-r1.ebuild b/dev-python/owslib/owslib-0.17.1-r1.ebuild
new file mode 100644
index 000000000000..29a6ac4beb8d
--- /dev/null
+++ b/dev-python/owslib/owslib-0.17.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="https://geopython.github.io/OWSLib"
+SRC_URI="https://github.com/geopython/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ || (
+ dev-python/elementtree[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="test" # tests require WAN access
+
+S="${WORKDIR}/OWSLib-${PV}"
+
+python_test() {
+ "${EPYTHON}" "${S}/setup.py" test || die
+}