summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-01-30 23:39:38 -0500
committerMike Gilbert <floppym@gentoo.org>2017-01-30 23:44:00 -0500
commit63207c8570eafab4e274685d9c62c0f19dd21a23 (patch)
tree60c7c7b660e74f6f530f21fd2f7db6f5479700d9 /dev-python/packaging/files
parentdev-python/pyparsing: force distutils to avoid circular dep with setuptools (diff)
downloadgentoo-63207c8570eafab4e274685d9c62c0f19dd21a23.tar.gz
gentoo-63207c8570eafab4e274685d9c62c0f19dd21a23.tar.bz2
gentoo-63207c8570eafab4e274685d9c62c0f19dd21a23.zip
dev-python/packaging: force distutils
Package-Manager: Portage-2.3.3_p42_p433273, Repoman-2.3.1_p35_p433273
Diffstat (limited to 'dev-python/packaging/files')
-rw-r--r--dev-python/packaging/files/packaging-16.8-distutils.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/packaging/files/packaging-16.8-distutils.patch b/dev-python/packaging/files/packaging-16.8-distutils.patch
new file mode 100644
index 000000000000..84bbb618a6fe
--- /dev/null
+++ b/dev-python/packaging/files/packaging-16.8-distutils.patch
@@ -0,0 +1,14 @@
+--- a/setup.py
++++ b/setup.py
+@@ -13,10 +13,7 @@ import re
+ # dependency when projects attempt to unbundle stuff from setuptools and pip.
+ # Though we don't really support that, it makes things easier if we do this and
+ # should hopefully cause less issues for end users.
+-try:
+- from setuptools import setup
+-except ImportError:
+- from distutils.core import setup
++from distutils.core import setup
+
+
+ base_dir = os.path.dirname(__file__)