summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-04 04:04:15 +0000
committerSam James <sam@gentoo.org>2021-12-04 04:04:15 +0000
commit38b9a5af3d07e19196a6de5c7fe85b84350d11d6 (patch)
tree59676ad7e9c15bc2cf3f6edfeec5e5683d8e4fea /dev-python/packaging/packaging-21.3-r1.ebuild
parentapp-shells/mcfly: re-add missing backslashes (diff)
downloadgentoo-38b9a5af3d07e19196a6de5c7fe85b84350d11d6.tar.gz
gentoo-38b9a5af3d07e19196a6de5c7fe85b84350d11d6.tar.bz2
gentoo-38b9a5af3d07e19196a6de5c7fe85b84350d11d6.zip
dev-python/packaging: allow older pyparsing too
Seem a few instances where Portage seems to get confused when trying to install Flatpak, so let's see if this helps (only pyparsing 3.0.5 was problematic for packaging). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/packaging/packaging-21.3-r1.ebuild')
-rw-r--r--dev-python/packaging/packaging-21.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/packaging/packaging-21.3-r1.ebuild b/dev-python/packaging/packaging-21.3-r1.ebuild
new file mode 100644
index 000000000000..2859ac290632
--- /dev/null
+++ b/dev-python/packaging/packaging-21.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/"
+SRC_URI="
+ https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ || (
+ >=dev-python/pyparsing-3.0.6[${PYTHON_USEDEP}]
+ <dev-python/pyparsing-3.0.5[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --capture=no
+}