summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-18 09:40:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-18 10:16:42 +0100
commit85b9d1b544b323964873f87f8d155e60b31d5a9d (patch)
tree40f328a44cfc010864ee7fb597a55689131b73da /dev-python/packaging/packaging-21.3.ebuild
parentdev-python/imageio: Bump to 2.11.0 (diff)
downloadgentoo-85b9d1b544b323964873f87f8d155e60b31d5a9d.tar.gz
gentoo-85b9d1b544b323964873f87f8d155e60b31d5a9d.tar.bz2
gentoo-85b9d1b544b323964873f87f8d155e60b31d5a9d.zip
dev-python/packaging: Bump to 21.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/packaging/packaging-21.3.ebuild')
-rw-r--r--dev-python/packaging/packaging-21.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/packaging/packaging-21.3.ebuild b/dev-python/packaging/packaging-21.3.ebuild
new file mode 100644
index 000000000000..5e12cb5f28f8
--- /dev/null
+++ b/dev-python/packaging/packaging-21.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/"
+SRC_URI="
+ https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/pyparsing-3.0.6[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --capture=no
+}