summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-20 15:53:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-20 16:05:18 +0100
commit2fbc0571c3dec2e39290334e128eca7487d28c0b (patch)
treea66e3af736baaeec1da440b4296c6d6ef02b6aba /dev-python/packaging
parentdev-php/pecl-event: fix USE=-sockets build with >=dev-lang/php-7.0 (diff)
downloadgentoo-2fbc0571c3dec2e39290334e128eca7487d28c0b.tar.gz
gentoo-2fbc0571c3dec2e39290334e128eca7487d28c0b.tar.bz2
gentoo-2fbc0571c3dec2e39290334e128eca7487d28c0b.zip
dev-python/packaging: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest3
-rw-r--r--dev-python/packaging/packaging-16.8.ebuild52
-rw-r--r--dev-python/packaging/packaging-19.2.ebuild51
-rw-r--r--dev-python/packaging/packaging-20.0.ebuild51
4 files changed, 0 insertions, 157 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 000c9a035391..701b98d5d3c4 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,5 +1,2 @@
-DIST packaging-16.8.tar.gz 44706 BLAKE2B 6443f05d3745eb6c4cc3d51fccfb1afcfa207ac12498be4d15cd0f5c52c80435f8ea513589e8aec671cf88b10cc8c98555e7cac7fe9a1e0c67f4625fce83f80f SHA512 d1a7b65472c7c02dd758f0c469d6c6aeea34de7b798613f7fcdf45fcccbeba1e9085cab113fa89b392a60f758f8747d13b1c265c809566990c22e61ca8db49bb
-DIST packaging-19.2.tar.gz 59110 BLAKE2B 8098538b8f48f4ff478eb13f3f4384d08c246b8a99711a48b2f412deaecd85faf13e24fd910a7a262c3407c5eb54939cd926e31e6f802deed0e28e0a92dfdb86 SHA512 af7312a85292f577d3e6e57154f10fb380bbdee749344ba4b226a09f22bf5ca664ed63c62cd5b4dea0be5eb5cff5c17ad04415aab8c925fa90dcae2e1c6dee5a
-DIST packaging-20.0.tar.gz 72663 BLAKE2B 39fe2c52389978d1c6d7a0a0044b549a96fd386f83ece2dac65090b8ea55193fb2334102523c5119ef29050655d81bc015e3b02c6589088ef6f5bc8e97f3aa04 SHA512 f7d99700d27d5aebbb3343f1de6ee9ce1372750b805c55a40d1a1fbeb6cfcfe2184875db56de175c6cd46e17f1567c30a39d5527870902c3c69168d025447587
DIST packaging-20.1.tar.gz 72955 BLAKE2B cd23c407693fcfd62c6fb40d996c3768201535cf6ba6dc825a6ee9e1b456a902aa730d1151e3b4e73fcc1193236dbd5ea9cfe6e17eefbc038d48aed12df9089b SHA512 1d51e81ab8b8c552d880ae3d210fe140835de181b6fcee3eb382f0f1d6a416e9cbdaeb52a81c50c53d2c5f5cdc40ee516f29ced845868a1bf7be3b23433f21d7
DIST packaging-20.3.tar.gz 73015 BLAKE2B 863a04124543d510455ffd6cd6974e7b3ed0c43e02baa5124631e24e7d56017d0289475fbcd9a4f038607c4a13aced32d2b98a82d975903afa154b520feb0019 SHA512 b27ad6f72bfe0965a6e6bff78e4e37d4cbab73dc0a1b019673c85615c9d99edf237effeb9756702c6e8c1575a2d981f6d1af364c73d0a451fbb167d64678630f
diff --git a/dev-python/packaging/packaging-16.8.ebuild b/dev-python/packaging/packaging-16.8.ebuild
deleted file mode 100644
index 4b36b5056453..000000000000
--- a/dev-python/packaging/packaging-16.8.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="https://github.com/pypa/packaging https://pypi.org/project/packaging/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-16.8-distutils.patch"
-)
-
-python_test() {
- py.test --capture=no --strict -v || die
-}
-
-pkg_preinst() {
- # https://bugs.gentoo.org/585146
- cd "${HOME}" || die
-
- _cleanup() {
- local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
- local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
- if [[ -d ${egginfo} ]]; then
- echo rm -r "${egginfo}"
- rm -r "${egginfo}" || die "Failed to remove egg-info directory"
- fi
- }
- python_foreach_impl _cleanup
-}
diff --git a/dev-python/packaging/packaging-19.2.ebuild b/dev-python/packaging/packaging-19.2.ebuild
deleted file mode 100644
index 2675f40b46c8..000000000000
--- a/dev-python/packaging/packaging-19.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="https://github.com/pypa/packaging https://pypi.org/project/packaging/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-16.8-distutils.patch"
-)
-
-python_test() {
- pytest --capture=no --strict -vv || die
-}
-
-pkg_preinst() {
- # https://bugs.gentoo.org/585146
- cd "${HOME}" || die
-
- _cleanup() {
- local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
- local egginfo="${ROOT}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
- if [[ -d ${egginfo} ]]; then
- rm -rv "${egginfo}" || die "Failed to remove egg-info directory"
- fi
- }
- python_foreach_impl _cleanup
-}
diff --git a/dev-python/packaging/packaging-20.0.ebuild b/dev-python/packaging/packaging-20.0.ebuild
deleted file mode 100644
index cbdf1bd94389..000000000000
--- a/dev-python/packaging/packaging-20.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="https://github.com/pypa/packaging https://pypi.org/project/packaging/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-16.8-distutils.patch"
-)
-
-python_test() {
- pytest --capture=no --strict -vv || die
-}
-
-pkg_preinst() {
- # https://bugs.gentoo.org/585146
- cd "${HOME}" || die
-
- _cleanup() {
- local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
- local egginfo="${ROOT}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
- if [[ -d ${egginfo} ]]; then
- rm -rv "${egginfo}" || die "Failed to remove egg-info directory"
- fi
- }
- python_foreach_impl _cleanup
-}