summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-22 11:36:16 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-22 11:36:25 +0100
commit3c53243e93a33d110212ede0d4271b2341071403 (patch)
tree00fe43a970d62a972d405525735fc3d4e7eec362 /dev-python/packaging
parentdev-db/4store: Improve deps #514750 (diff)
downloadgentoo-3c53243e93a33d110212ede0d4271b2341071403.tar.gz
gentoo-3c53243e93a33d110212ede0d4271b2341071403.tar.bz2
gentoo-3c53243e93a33d110212ede0d4271b2341071403.zip
dev-python/packaging: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-16.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 4ae1227d06ca..370cd3183859 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -2,3 +2,4 @@ DIST packaging-15.3.tar.gz 34359 SHA256 1e9a6b9ad621bc1dbd3aa8dfff52abc4b44f5c14
DIST packaging-16.0.tar.gz 40167 SHA256 a32895134cd7b86ee8add60a3be5bfd7ef3f30e73e5b54221dbe67d0e0690689 SHA512 7672f0a51f73543e39ad80b021d288c0e235c2ace9add5022a1d494b2711ce55ba7d05d92245cbb96fa354d67fdfbdbdd2e1858ace3d6d2761869bc5ddaaeddd WHIRLPOOL be813ffbcc614e5be3bc9bb1e704e9c65c194b47172bb0c9bf0113ea8456256fa8263faec33b3e001b6d71ed7fd8763796afd6eeb608f3a65ea987db48304d5a
DIST packaging-16.1.tar.gz 42929 SHA256 7792caf5bfda630c96310a84ecba5d61b17a843ab72194bb5606d81e4f44094f SHA512 f4e081be85247c989343e7532d5e4afcad68af960264b59271862799e8d63ed0b7fb733670f7446da69aa60f013fc886c8c31c6010c1157110c1a417209d9325 WHIRLPOOL 8c13ef4196633cc4c7c59aef2fa8980abc46908fd30ffbe79d565dcd6089bc1496a8b5dc6aa5968273281e8ef494ef54036c72192f36dfe30dbb0f3fcf8544c9
DIST packaging-16.2.tar.gz 43398 SHA256 0eb4a6329c6d40a0deef725b4f510b6219ec8c365f888583babbb4454d761dd6 SHA512 2310efbd4d73498d5645d0c3a2f0cb162cd18cff28079ba2ac44b784e728363d84a8eae4d9e313c4491394841638ef01ef37ef7da3bac01e27af37a72e387dd1 WHIRLPOOL 5aff538bf5ee18474074048bb581140200c078ceb6366f5c709be931851b0835a8a725ecc17a1b2c34bae34cf79d8743a4422c6701e5c6e9ba99bfdc51aa439f
+DIST packaging-16.3.tar.gz 43580 SHA256 46e5808cdfd3766d41d3691d413ca3515bd060f16fca5aab080d5a6a204ec33c SHA512 54f8a4c6f27c0e31c40d4fa2109b14228d2434442407291363781979aa99c5bb02e6c8040f529d8efdc4a3f001e1028754c09eba11217e9374b8456f0e735413 WHIRLPOOL 3b785d1f71e4bda45b809dcb82b393ba18c2b0111c75671e8376e58884d4412ab8eeba5c480085decb27fe171b2e99d9763db7b5698bbb2922bac97c34a35e6c
diff --git a/dev-python/packaging/packaging-16.3.ebuild b/dev-python/packaging/packaging-16.3.ebuild
new file mode 100644
index 000000000000..26279ce494d2
--- /dev/null
+++ b/dev-python/packaging/packaging-16.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ py.test --capture=no --strict -v || die
+}
+
+pkg_preinst() {
+ # Remove this in the next version bump
+ _cleanup() {
+ local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
+ local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
+ if [[ -d ${egginfo} ]]; then
+ echo rm -r "${egginfo}"
+ rm -r "${egginfo}" || die "Failed to remove egg-info directory"
+ fi
+ }
+ python_foreach_impl _cleanup
+}