summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-05-12 21:47:58 +1000
committerSam Jorna <wraeth@gentoo.org>2016-05-12 21:53:02 +1000
commit27352e65534e51a5a748ab63415f83cb8495b397 (patch)
treec66280926868bcc5d6ad4bb54c01d24bb5f9b6c0 /dev-python/paho-mqtt
parentpackage.mask: Unmask llvm-3.8 (diff)
downloadgentoo-27352e65534e51a5a748ab63415f83cb8495b397.tar.gz
gentoo-27352e65534e51a5a748ab63415f83cb8495b397.tar.bz2
gentoo-27352e65534e51a5a748ab63415f83cb8495b397.zip
dev-python/paho-mqtt: new package
Python mqtt library that was previously a part of app-misc/mosquitto, and is a client class which enable applications to connect to an MQTT broker. Ebuild by Proxied Maintainer Neil Bothwick per bug. Gentoo-bug: 582722 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/paho-mqtt')
-rw-r--r--dev-python/paho-mqtt/Manifest1
-rw-r--r--dev-python/paho-mqtt/metadata.xml12
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.1.ebuild17
3 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
new file mode 100644
index 000000000000..6930bbc56b61
--- /dev/null
+++ b/dev-python/paho-mqtt/Manifest
@@ -0,0 +1 @@
+DIST paho-mqtt-1.1.zip 159529 SHA256 e8585df21f12d0af6295b1484d894d79376621d1cf33f02c26a811d09d6d8efa SHA512 ef6d1a29480671413dbb655bd8f668b99f8587c14589d2180a37142b368e0ce058f8ed967dbfaa82f239c86e295338bc35c9f28a3ea39d21a6034cd8787a63ce WHIRLPOOL 675891b1e26e00a04d1ba7c740a9846d7c4a34a7bafa7e33e9b233bc213e8bda52eda5b85153b8606786d96142889f8dd61d06c85548c4d0e7480047a90d395f
diff --git a/dev-python/paho-mqtt/metadata.xml b/dev-python/paho-mqtt/metadata.xml
new file mode 100644
index 000000000000..af9de97a426e
--- /dev/null
+++ b/dev-python/paho-mqtt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>neil@digimed.co.uk</email>
+ <name>Neil Bothwick</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.1.ebuild
new file mode 100644
index 000000000000..0cc4b9997ec1
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1 on Python 2.7 or 3.x."
+HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/${PV}.zip -> ${P}.zip"
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/paho.mqtt.python-${PV}"