summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-01-15 15:34:48 -0800
committerMatt Turner <mattst88@gentoo.org>2020-01-15 15:46:23 -0800
commit49a077f7db2ebd4376e02aeeeebff292aabec6aa (patch)
treef4ee620f5a48f9139c7ec23881e966d5c8a30273 /dev-python/paho-mqtt
parentnet-analyzer/wireshark: Reorganise KEYWORDS (diff)
downloadgentoo-49a077f7db2ebd4376e02aeeeebff292aabec6aa.tar.gz
gentoo-49a077f7db2ebd4376e02aeeeebff292aabec6aa.tar.bz2
gentoo-49a077f7db2ebd4376e02aeeeebff292aabec6aa.zip
dev-python/paho-mqtt: Version bump to 1.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/paho-mqtt')
-rw-r--r--dev-python/paho-mqtt/Manifest1
-rw-r--r--dev-python/paho-mqtt/files/paho-mqtt-1.5.0-strip-test-dependency.patch31
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild38
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
index 221aa29a5623..4cb8fa1c4954 100644
--- a/dev-python/paho-mqtt/Manifest
+++ b/dev-python/paho-mqtt/Manifest
@@ -1 +1,2 @@
DIST paho-mqtt-1.4.0.tar.gz 108278 BLAKE2B 0569f3cb5d262b3b7f6ae68261fe138d839afcc6fe91f880e29de24d5cf8e2491af81a30eb82c27fe63eee90114326eb75b06a32e05ec2fffed27b92d9601902 SHA512 2e49f0f146207ab4fbc8c346b10d3e2b50869b2d9db7c999b6645f7213fb635b64cff01c5405e7833a8b25334d24685ce6ed734a6e4b6b0660b48f65cf4a941c
+DIST paho-mqtt-1.5.0.tar.gz 126869 BLAKE2B 2dce27c1fcfe7ae422dc6da76fb58e7901de00c0c349b9715c56a3603da26e1f46af9bb8c0bd982043ba54a2070655b483d251a0a847e1c3afb36bcd4cfcdba8 SHA512 7e52180bf1783ee1f39aa5248730e82fae47fe3db7c4579b0b7207a29f5337c7c0af58d58aac1c265b1ed91fa9c240187d5e3005f55c6e28623e6cbc36750294
diff --git a/dev-python/paho-mqtt/files/paho-mqtt-1.5.0-strip-test-dependency.patch b/dev-python/paho-mqtt/files/paho-mqtt-1.5.0-strip-test-dependency.patch
new file mode 100644
index 000000000000..9c8307359337
--- /dev/null
+++ b/dev-python/paho-mqtt/files/paho-mqtt-1.5.0-strip-test-dependency.patch
@@ -0,0 +1,31 @@
+# Remove Pylama from test dependencies.
+
+diff --git a/setup.cfg b/setup.cfg
+index 84551cd..73bd714 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,9 +1,6 @@
+ [aliases]
+ test=pytest
+ [tool:pytest]
+-addopts=-r xs --pylama
++addopts=-r xs
+ strict=True
+ testpaths=tests src
+-[pylama]
+-linters=pyflakes
+-skip=tests/*
+diff --git a/setup.py b/setup.py
+index 8441de1..2878352 100644
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@ with open('README.rst', 'rb') as readme_file:
+ readme = readme_file.read().decode('utf-8')
+
+ requirements = []
+-test_requirements = ['pytest', 'pylama', 'six']
++test_requirements = ['pytest', 'six']
+ needs_pytest = {'pytest', 'test', 'ptr'}.intersection(sys.argv)
+ setup_requirements = ['pytest-runner'] if needs_pytest else []
+ extra_requirements = {'proxy': ['PySocks']}
+--
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild
new file mode 100644
index 000000000000..dbeecd0ba64b
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1"
+HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ) "
+
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+#RESTRICT="test" #659106
+
+src_prepare() {
+ eapply "${FILESDIR}/${P}-strip-test-dependency.patch"
+ default
+}
+
+python_test() {
+ esetup.py test
+}