summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-07-26 09:22:38 +0200
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:34:48 +0200
commitce6f55c911351ab456d1a8c463a251191bad4d2b (patch)
treef74f133f051f7a03748fd4c809e8cfb19ff6a8e9 /dev-python/pandocfilters
parentdev-python/jupyter_client: Version bump to 5.1.0 (diff)
downloadgentoo-ce6f55c911351ab456d1a8c463a251191bad4d2b.tar.gz
gentoo-ce6f55c911351ab456d1a8c463a251191bad4d2b.tar.bz2
gentoo-ce6f55c911351ab456d1a8c463a251191bad4d2b.zip
dev-python/pandocfilters: Utilities for writing pandoc filters in python
A python module for writing `pandoc <http: pandoc.org=""/>`_ filters Pandoc filters are pipes that read a JSON serialization of the Pandoc AST from stdin, transform it in some way, and write it to stdout. The package is required for dev-python/nbconvert-5.0.0 and higher. Gentoo-Bug: https://bugs.gentoo.org/626194 Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5217
Diffstat (limited to 'dev-python/pandocfilters')
-rw-r--r--dev-python/pandocfilters/Manifest2
-rw-r--r--dev-python/pandocfilters/metadata.xml12
-rw-r--r--dev-python/pandocfilters/pandocfilters-1.2.4.ebuild21
-rw-r--r--dev-python/pandocfilters/pandocfilters-1.4.1.ebuild21
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pandocfilters/Manifest b/dev-python/pandocfilters/Manifest
new file mode 100644
index 000000000000..5772a4a9a62e
--- /dev/null
+++ b/dev-python/pandocfilters/Manifest
@@ -0,0 +1,2 @@
+DIST pandocfilters-1.2.4.tar.gz 7296 SHA256 e2c8e9820e89e52a882b26d3242dccb5931d3a1174d5f6bc31f8ee9e8b37b3cc SHA512 3f819aebc4380ceee57e521e958bb7d29d806d2bfe3c9bddd30661d143069e39b0df79283d6c7ee85ee40fa4fa10df68fa40200395145e47b63fa96177ec226b WHIRLPOOL 676fab4a9fb0d2f872187d3c739e63e08ef49caba405d9646ceec29a948318989f85410bbf1cb9c24c74f93c343cf9e4db3fc2b3390aa95694d7a93062d970bb
+DIST pandocfilters-1.4.1.tar.gz 14265 SHA256 ec8bcd100d081db092c57f93462b1861bcfa1286ef126f34da5cb1d969538acd SHA512 658976a635d6a5783448e18989192ee474f933cea7a4a91c3ec706b097fafd98251e62bbe3649d3779c99bafdadf9a9c1cac6916116aeb16631ad7434de1c9fe WHIRLPOOL 69fdc1ee029dba775123b7901cc7013c5a89f3da8b9ca94a135e606a60c9eac5ea61093e4810cd099984d3e6495bc6f1f084f57c183daac8ca4ef668c73bced7
diff --git a/dev-python/pandocfilters/metadata.xml b/dev-python/pandocfilters/metadata.xml
new file mode 100644
index 000000000000..18d97df8a656
--- /dev/null
+++ b/dev-python/pandocfilters/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pandocfilters</remote-id>
+ <remote-id type="github">jgm/pandocfilters</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pandocfilters/pandocfilters-1.2.4.ebuild b/dev-python/pandocfilters/pandocfilters-1.2.4.ebuild
new file mode 100644
index 000000000000..4b6a2795fb69
--- /dev/null
+++ b/dev-python/pandocfilters/pandocfilters-1.2.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utilities for writing pandoc filters in python"
+HOMEPAGE="https://github.com/jgm/pandocfilters"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="<=app-text/pandoc-1.15"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/pandocfilters/pandocfilters-1.4.1.ebuild b/dev-python/pandocfilters/pandocfilters-1.4.1.ebuild
new file mode 100644
index 000000000000..5e8cdaa40da6
--- /dev/null
+++ b/dev-python/pandocfilters/pandocfilters-1.4.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utilities for writing pandoc filters in python"
+HOMEPAGE="https://github.com/jgm/pandocfilters"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=app-text/pandoc-1.16"
+DEPEND="${RDEPEND}"