summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 05:46:19 +0000
committerSam James <sam@gentoo.org>2020-12-31 06:07:44 +0000
commit144da4872e65ee51d9db4925d0066dffa2c680bd (patch)
tree79429705f811adc5ff81944159c92d2a95051018 /dev-python/parso
parentsci-misc/cdfplayer: bump to 12.2.0 (diff)
downloadgentoo-144da4872e65ee51d9db4925d0066dffa2c680bd.tar.gz
gentoo-144da4872e65ee51d9db4925d0066dffa2c680bd.tar.bz2
gentoo-144da4872e65ee51d9db4925d0066dffa2c680bd.zip
dev-python/parso: bump to 0.8.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest1
-rw-r--r--dev-python/parso/parso-0.8.1.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index 3353336f2a49..6e1363e87f8f 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1,3 +1,4 @@
DIST parso-0.7.0.tar.gz 395175 BLAKE2B ac407b711b6229a93864e339b3632563d3fcd7f84e22a43bd89282300b931f58d638ab8a64c441dc183852576261be18a3be471b0824b6e56fb69025cf666d6b SHA512 41ad60b1d7dff682281059aabff0d43ccd3048b6cc6ee3e9e141d4a0a965fd99449f6d3f23689914c1f7bda371e3cc86266775a1c23fb1c430ea689c916fbb71
DIST parso-0.7.1.tar.gz 399842 BLAKE2B 1e47c1dd6846d01aa5820d7cedc3eafcf12ea0d4a2e95fa3f54429633b1c12dc39a4abe237fa46eb629408006777bd1f512cf878025b55119568ac19729b8c19 SHA512 318969a7a941c4a0948e58643b07b6f5c446ea166b3a8e44a556f0677ec9a36d7dc8c6d37ca7bce3f8276ee3d7144e22fbaaeac90c738fb90f7e94a0cf8abf7d
DIST parso-0.8.0.tar.gz 392579 BLAKE2B b816a9f54aca54fbb8df772d1f6501d55fccef91d3c9bfcddc9f069e1b5a15dee7742bf37dbfd07f26253247a29a42303c4034608c6c9991c97e55acac77b69d SHA512 fe9d1c46cb128d6af9c45f333e49475da795c1ed67572891f4daf08af620814b9db18469be11f771869e0f44acea9446e1419067e1b72affc1cb669a277d6a2c
+DIST parso-0.8.1.tar.gz 393403 BLAKE2B d8d2a025dfb6664d8deeabfc621f4dcf0c6f6e0769dc3a7081888436cce39685f7749ee4ed33c501e3690bec0c8b21d18195d585a8baf5fa8c1b1ae1bfad5680 SHA512 10cc36a4f288d06b8d06bf3995eafe8c6b5d46d0ab01ce6db4557c82f8c64c6792b438a5b7dea570a9690bad586ab4216161268be9c1979b91b3af50e1c8801c
diff --git a/dev-python/parso/parso-0.8.1.ebuild b/dev-python/parso/parso-0.8.1.ebuild
new file mode 100644
index 000000000000..e5da1da9a57f
--- /dev/null
+++ b/dev-python/parso/parso-0.8.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest