summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-11 12:39:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-11 19:06:32 -0500
commit083f371f720dcfbddc292f5f172e31d62c66552a (patch)
treeaf48d5aca86d5a55018647227e127e13d5c6a790 /dev-python/passlib
parentmate-base/mate-applets revert backport kernel 4.7 support (diff)
downloadgentoo-083f371f720dcfbddc292f5f172e31d62c66552a.tar.gz
gentoo-083f371f720dcfbddc292f5f172e31d62c66552a.tar.bz2
gentoo-083f371f720dcfbddc292f5f172e31d62c66552a.zip
doing the test
Diffstat (limited to 'dev-python/passlib')
-rw-r--r--dev-python/passlib/Manifest2
-rw-r--r--dev-python/passlib/passlib-1.6.1-r1.ebuild30
-rw-r--r--dev-python/passlib/passlib-1.6.2.ebuild39
-rw-r--r--dev-python/passlib/passlib-1.6.5-r1.ebuild2
-rw-r--r--dev-python/passlib/passlib-1.6.5.ebuild32
5 files changed, 1 insertions, 104 deletions
diff --git a/dev-python/passlib/Manifest b/dev-python/passlib/Manifest
index bd78977eed38..f3f0b7fd5ab4 100644
--- a/dev-python/passlib/Manifest
+++ b/dev-python/passlib/Manifest
@@ -1,3 +1 @@
-DIST passlib-1.6.1.tar.gz 395855 SHA256 00cfb564feb2d97ebaf6b28acdc9277a0c73c3c1df7b2a7b65605c76e724177b SHA512 93c047dc0a06f19a20e5da97db43c5c76e06d69baeac15cc932ef0306ae22dac5c1a3925889a140fd181ab4e00ac513ec829951e15babf5aad89bd2d08dc9907 WHIRLPOOL b0840a1fd903000db06c1739d902e01c3cc4fb9f63692b0316fd60bd3393fa5be134037476da135306cc258fe38853269ebbb424d13f45edda9dd1c1b370d957
-DIST passlib-1.6.2.tar.gz 408950 SHA256 e987f6000d16272f75314c7147eb015727e8532a3b747b1a8fb58e154c68392d SHA512 4c58df875549d9d4a5a9cb5d7b8e853b2614cab1c67a35d0d113fcd6332bbe0f5b6d2521d71eade2e020d0a42cd9ce0a6e866c82bc1a840391f9005ba0baceea WHIRLPOOL 74bc9eceb460108d435eb25a46db1dd91acef146c4972fffcd065a8774247faf423ddcb3bfe6d143a65b1f2a681aa562424ba881bf71e088633aa201c7ceb3d9
DIST passlib-1.6.5.tar.gz 417044 SHA256 a83d34f53dc9b17aa42c9a35c3fbcc5120f3fcb07f7f8721ec45e6a27be347fc SHA512 b5323834a0a7fc7e799882c512a2fcaddb0cbf4dbfb3ec578c9a9ea7a7f08349335cd3124fe2b379eef265ecdf9d823b7562951881710cf4dafff128a65c82d4 WHIRLPOOL ed9f190557fe9b1994dc30a38bdcdcd9c2275e6a32c17a8159b034c7dd49cf8531020f5c6e53301c1fca89b0e5abd1692072faa6e050fd8edbf877b197b8afae
diff --git a/dev-python/passlib/passlib-1.6.1-r1.ebuild b/dev-python/passlib/passlib-1.6.1-r1.ebuild
deleted file mode 100644
index 3ec9fb037868..000000000000
--- a/dev-python/passlib/passlib-1.6.1-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Password hashing framework supporting over 20 schemes"
-HOMEPAGE="https://code.google.com/p/passlib/"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="test doc"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-python_test() {
- nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
-}
diff --git a/dev-python/passlib/passlib-1.6.2.ebuild b/dev-python/passlib/passlib-1.6.2.ebuild
deleted file mode 100644
index 1804c1640e2f..000000000000
--- a/dev-python/passlib/passlib-1.6.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Password hashing framework supporting over 20 schemes"
-HOMEPAGE="https://code.google.com/p/passlib/"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-KEYWORDS="amd64 x86"
-SLOT="0"
-IUSE="test doc"
-
-RDEPEND="dev-python/bcrypt[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # https://code.google.com/p/passlib/issues/detail?id=50
- # py3 on testing choaks on the suite
- if ! python_is_python3; then
- nosetests -w "${BUILD_DIR}"/lib \
- -e test_90_django_reference -e test_91_django_generation \
- -e test_77_fuzz_input -e test_config \
- -e test_registry.py || die "Tests fail with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
-}
diff --git a/dev-python/passlib/passlib-1.6.5-r1.ebuild b/dev-python/passlib/passlib-1.6.5-r1.ebuild
index 2a10e689ca87..a0f0a0371ccf 100644
--- a/dev-python/passlib/passlib-1.6.5-r1.ebuild
+++ b/dev-python/passlib/passlib-1.6.5-r1.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://bitbucket.org/ecollins/passlib/wiki/Home/"
SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
SLOT="0"
IUSE="test doc"
diff --git a/dev-python/passlib/passlib-1.6.5.ebuild b/dev-python/passlib/passlib-1.6.5.ebuild
deleted file mode 100644
index 817616ce8a47..000000000000
--- a/dev-python/passlib/passlib-1.6.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Password hashing framework supporting over 20 schemes"
-HOMEPAGE="https://bitbucket.org/ecollins/passlib/wiki/Home/"
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~arm64 ~x86"
-SLOT="0"
-IUSE="test doc"
-
-RDEPEND="dev-python/bcrypt[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
-}