summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-04 13:35:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-04 13:36:32 +0100
commit003d59f8dde31b26fb2adc2cffba4c06e0a426e5 (patch)
tree6b830bcfc60714e18447634582e8cf8f669eea02 /dev-python/paste/paste-3.5.0.ebuild
parentRevert "dev-python/google-auth: Remove namespace dep" (diff)
downloadgentoo-003d59f8dde31b26fb2adc2cffba4c06e0a426e5.tar.gz
gentoo-003d59f8dde31b26fb2adc2cffba4c06e0a426e5.tar.bz2
gentoo-003d59f8dde31b26fb2adc2cffba4c06e0a426e5.zip
Revert "dev-python/paste: Remove namespace dep"
This reverts commit 19235b01e5c62d44ae0245bfd1c8d267fd2b294b. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paste/paste-3.5.0.ebuild')
-rw-r--r--dev-python/paste/paste-3.5.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/paste/paste-3.5.0.ebuild b/dev-python/paste/paste-3.5.0.ebuild
new file mode 100644
index 000000000000..ceb33d7884b9
--- /dev/null
+++ b/dev-python/paste/paste-3.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+MY_P="Paste-${PV}"
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="https://pypi.org/project/Paste/"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # TODO: 'Address already in use'
+ sed -e 's:test_address_family_v4:_&:' \
+ -i tests/test_httpserver.py || die
+
+ # Remove a test that runs against the paste website.
+ rm -f tests/test_proxy.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${D}" -name '*.pth' -delete || die
+}