summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-05 19:15:44 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-05 19:53:43 +0300
commit998d1ae41d7ee67322105d13d8d1fa5496d7812d (patch)
treea93c3ad8a9bbb0f3c1702d5001610611ba2bc210 /dev-python/patatt
parentdev-python/pbkdf2: enable py3.11 (diff)
downloadgentoo-998d1ae41d7ee67322105d13d8d1fa5496d7812d.tar.gz
gentoo-998d1ae41d7ee67322105d13d8d1fa5496d7812d.tar.bz2
gentoo-998d1ae41d7ee67322105d13d8d1fa5496d7812d.zip
dev-python/patatt: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/patatt')
-rw-r--r--dev-python/patatt/patatt-0.4.9-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/patatt/patatt-0.4.9-r1.ebuild b/dev-python/patatt/patatt-0.4.9-r1.ebuild
new file mode 100644
index 000000000000..9d63be6a35cb
--- /dev/null
+++ b/dev-python/patatt/patatt-0.4.9-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple library to add cryptographic attestation to patches sent via email"
+HOMEPAGE="https://pypi.org/project/patatt/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pynacl[${PYTHON_USEDEP}]"