summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-26 10:13:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-26 10:13:46 +0200
commit9d1e961a7514605b0244340167f164c541e59c69 (patch)
treea52099bce3fc41c725323406f1c7bd14d839e43d /dev-python/path-py/path-py-16.0.0.ebuild
parentdev-python/iso8601: Remove old (diff)
downloadgentoo-9d1e961a7514605b0244340167f164c541e59c69.tar.gz
gentoo-9d1e961a7514605b0244340167f164c541e59c69.tar.bz2
gentoo-9d1e961a7514605b0244340167f164c541e59c69.zip
dev-python/path-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path-py/path-py-16.0.0.ebuild')
-rw-r--r--dev-python/path-py/path-py-16.0.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/path-py/path-py-16.0.0.ebuild b/dev-python/path-py/path-py-16.0.0.ebuild
deleted file mode 100644
index b0bfdc1c94dc..000000000000
--- a/dev-python/path-py/path-py-16.0.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-MY_P="path-${PV}"
-DESCRIPTION="A module wrapper for os.path"
-HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
-SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- !<dev-python/pytest-shutil-1.7.0-r1
- !<dev-python/pytest-virtualenv-1.7.0-r1"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # unreliable, not really meaningful for end users
- test_path.py::TestPerformance
- )
-
- epytest ${deselect[@]/#/--deselect }
-}