summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-04 09:22:45 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-04 12:19:28 +0100
commit8f907b3b598d282fdf4ed0c2df36fbd212151eac (patch)
treef84a84e280391f5ce55c89e8dd02a1fb246483a5 /dev-python/pathlib2/pathlib2-2.3.0.ebuild
parentsys-devel/automake: stable 1.15.1-r2 for sparc, bug #522638 (diff)
downloadgentoo-8f907b3b598d282fdf4ed0c2df36fbd212151eac.tar.gz
gentoo-8f907b3b598d282fdf4ed0c2df36fbd212151eac.tar.bz2
gentoo-8f907b3b598d282fdf4ed0c2df36fbd212151eac.zip
dev-python/pathlib2: Add missing test-DEP on dev-python/mock
Closes: https://bugs.gentoo.org/649536
Diffstat (limited to 'dev-python/pathlib2/pathlib2-2.3.0.ebuild')
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pathlib2/pathlib2-2.3.0.ebuild b/dev-python/pathlib2/pathlib2-2.3.0.ebuild
index c23057673735..c95eda55919d 100644
--- a/dev-python/pathlib2/pathlib2-2.3.0.ebuild
+++ b/dev-python/pathlib2/pathlib2-2.3.0.ebuild
@@ -14,13 +14,15 @@ SRC_URI="mirror://pypi/p/pathlib2/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
- $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' 'python2*' python3_4 pypy )
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 python3_4 )
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2) )"
python_test() {
"${EPYTHON}" test_pathlib2.py || die