summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-27 07:46:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 08:10:51 +0200
commit4ea700fe890854944f70c3cdfa37a435caaf3631 (patch)
treef06767057ba7801adc5f55c081abc91734e3b02e /dev-python/pathlib2/pathlib2-2.3.5.ebuild
parentdev-python/entrypoints: Port to py39 (diff)
downloadgentoo-4ea700fe890854944f70c3cdfa37a435caaf3631.tar.gz
gentoo-4ea700fe890854944f70c3cdfa37a435caaf3631.tar.bz2
gentoo-4ea700fe890854944f70c3cdfa37a435caaf3631.zip
dev-python/pathlib2: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pathlib2/pathlib2-2.3.5.ebuild')
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pathlib2/pathlib2-2.3.5.ebuild b/dev-python/pathlib2/pathlib2-2.3.5.ebuild
index e080b52fd1ad..fcfb7cdfd59b 100644
--- a/dev-python/pathlib2/pathlib2-2.3.5.ebuild
+++ b/dev-python/pathlib2/pathlib2-2.3.5.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8,9}} )
inherit distutils-r1
@@ -18,11 +19,10 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 )
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2)
dev-python/six[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)