summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-26 04:45:20 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-26 04:45:54 -0700
commit10409e638a04266af71a61e85367f03f7cc90bcb (patch)
tree38caaf2c90a61d9c4d465ab71728d60a016f0e95 /dev-python/pathspec
parentapp-text/hunspell: Drop 1.6.2-r1 (diff)
downloadgentoo-10409e638a04266af71a61e85367f03f7cc90bcb.tar.gz
gentoo-10409e638a04266af71a61e85367f03f7cc90bcb.tar.bz2
gentoo-10409e638a04266af71a61e85367f03f7cc90bcb.zip
dev-python/pathspec: version bump to 0.7.0
Drop py27 support. Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/pathspec')
-rw-r--r--dev-python/pathspec/Manifest1
-rw-r--r--dev-python/pathspec/pathspec-0.7.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pathspec/Manifest b/dev-python/pathspec/Manifest
index 9c3c4f13f22e..4e3c32da8bb9 100644
--- a/dev-python/pathspec/Manifest
+++ b/dev-python/pathspec/Manifest
@@ -1 +1,2 @@
DIST pathspec-0.6.0.tar.gz 24159 BLAKE2B ac3f75d7f4b3f6d092d216176823f061fe91f3bead10947b01315267655133a0f99a29288283cbeeff7c2c9305c499b4ade1efcdccc554d756ecaaae2f84896c SHA512 e08baa05a3fe58ec6ecd651577834115cdeef26b75eef274d843c3c6444cf771e86f99a2a2b2980a6d1ece946997f1ebe714f79ddd5c296071c2e18b73955a84
+DIST pathspec-0.7.0.tar.gz 24306 BLAKE2B 4256a658de2160d3487281dcb5a488c804320ec5b0bd8e20fdaf51bef8fc90f4e7fb48c404ce43508633c23d866b41e7e13cfa3897929459b244e75401b84ca1 SHA512 3171d39405eb586945261b11781b966e0771649dd7caa8f8a5bbd26223a37931c17bd50a4706d603a637a10460e9b3730c21f0eff7dc92d7e73ae570641a900c
diff --git a/dev-python/pathspec/pathspec-0.7.0.ebuild b/dev-python/pathspec/pathspec-0.7.0.ebuild
new file mode 100644
index 000000000000..721c75372081
--- /dev/null
+++ b/dev-python/pathspec/pathspec-0.7.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for gitignore style pattern matching of file paths."
+HOMEPAGE="https://github.com/cpburnz/python-path-specification https://pypi.org/project/pathspec/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}