summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-09 08:52:23 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:41 +0100
commit3f1086a97d0debb9251000f1337d2c5973fa5819 (patch)
treed827b9195840473385477badcb3bb6b1a0993614 /dev-python/patsy/patsy-0.4.1.ebuild
parentdev-lang/ruby: amd64 stable wrt bug #565110 (diff)
downloadgentoo-3f1086a97d0debb9251000f1337d2c5973fa5819.tar.gz
gentoo-3f1086a97d0debb9251000f1337d2c5973fa5819.tar.bz2
gentoo-3f1086a97d0debb9251000f1337d2c5973fa5819.zip
dev-python/patsy: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/patsy/patsy-0.4.1.ebuild')
-rw-r--r--dev-python/patsy/patsy-0.4.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/patsy/patsy-0.4.1.ebuild b/dev-python/patsy/patsy-0.4.1.ebuild
new file mode 100644
index 000000000000..a669cf1691cf
--- /dev/null
+++ b/dev-python/patsy/patsy-0.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}