summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/patsy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/patsy')
-rw-r--r--dev-python/patsy/Manifest3
-rw-r--r--dev-python/patsy/metadata.xml13
-rw-r--r--dev-python/patsy/patsy-0.2.0.ebuild42
-rw-r--r--dev-python/patsy/patsy-0.2.1.ebuild42
-rw-r--r--dev-python/patsy/patsy-0.3.0-r1.ebuild44
-rw-r--r--dev-python/patsy/patsy-0.3.0.ebuild42
6 files changed, 186 insertions, 0 deletions
diff --git a/dev-python/patsy/Manifest b/dev-python/patsy/Manifest
new file mode 100644
index 000000000000..31c617b218d7
--- /dev/null
+++ b/dev-python/patsy/Manifest
@@ -0,0 +1,3 @@
+DIST patsy-0.2.0.tar.gz 315486 SHA256 1d399e504dc7c9e5f35460698dd4ebf098aa215e861ea4f5ded29e98e73740c3 SHA512 4e1028dcab58e2fc938c4f8dec0aeb148fbf7d2430855d8caa844bc19088b66a8ab9b83edc3f3066df41e751f1e0ff6d24478109be562e420da6c84e3f76763f WHIRLPOOL 2da9956373cc9bd2f13d277bcca37467ab8f5b37223f9c6bf6d59b6c69e7c54bdcc70433c990ea4a02aa424c497be08031966963721194af308cda1bb36edb13
+DIST patsy-0.2.1.tar.gz 316115 SHA256 31374ce25275813d8f1c48bdda40bba06f7a16cce7dcdfad73f43a555393d065 SHA512 b7cbd9b224081b2496292b23c134abfdd9decedfda433bc7c289b899003c527184e0ba0f729eca1f3bceceac0c43090d9b611b8b1f593df5ce2a01129fabf9f6 WHIRLPOOL 91b8bc896146e48c272429482d3294a35cbc0a46662e66b913811491b2d89005371dc6eb09f38a4a043e507fba3b359dcf3a1fc61e9bf88c462c8b9ebeb995d9
+DIST patsy-0.3.0.zip 414947 SHA256 a55dd4ca09af4b9608b81f30322beb450510964c022708ab50e83a065ccf15f0 SHA512 e716588372ca5c2cb8923b5a04c11be4911cb44e7af2c82ebf92aba478bd9ec6707bea5abfa11439038a6be7522c80fb5d67d452725669f38bc81bc9a0c1e2e8 WHIRLPOOL c0e82d8f15961d4954245c7abe03973b8f660c58e57962dbb3d0523a6a544d4a922c578f3394d72e00ca5656ed5a552aeab5633317bf52d33fd856e135094c30
diff --git a/dev-python/patsy/metadata.xml b/dev-python/patsy/metadata.xml
new file mode 100644
index 000000000000..5296bb5bc086
--- /dev/null
+++ b/dev-python/patsy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription>
+ A Python package for describing statistical models and for building
+ design matrices. It is closely inspired by and compatible with the
+ 'formula' mini-language used in R and S.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">patsy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/patsy/patsy-0.2.0.ebuild b/dev-python/patsy/patsy-0.2.0.ebuild
new file mode 100644
index 000000000000..e7fa8e258f5d
--- /dev/null
+++ b/dev-python/patsy/patsy-0.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython
+ dev-python/matplotlib
+ dev-python/sphinx )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/_build/html/*
+}
diff --git a/dev-python/patsy/patsy-0.2.1.ebuild b/dev-python/patsy/patsy-0.2.1.ebuild
new file mode 100644
index 000000000000..e7fa8e258f5d
--- /dev/null
+++ b/dev-python/patsy/patsy-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython
+ dev-python/matplotlib
+ dev-python/sphinx )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/_build/html/*
+}
diff --git a/dev-python/patsy/patsy-0.3.0-r1.ebuild b/dev-python/patsy/patsy-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..fec3066e0249
--- /dev/null
+++ b/dev-python/patsy/patsy-0.3.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/_build/html/*
+}
diff --git a/dev-python/patsy/patsy-0.3.0.ebuild b/dev-python/patsy/patsy-0.3.0.ebuild
new file mode 100644
index 000000000000..ebc5e84d7f19
--- /dev/null
+++ b/dev-python/patsy/patsy-0.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/_build/html/*
+}