summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-12 14:31:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-12 15:20:17 +0200
commit88cb1fdfbfdc14408b5c0e847f5323e6be313d76 (patch)
tree34c093f2f8dc0b0e1e9524b889a35ce2eebc652f /dev-python/patsy
parentdev-ruby/net-ssh: add missing dependency (diff)
downloadgentoo-88cb1fdfbfdc14408b5c0e847f5323e6be313d76.tar.gz
gentoo-88cb1fdfbfdc14408b5c0e847f5323e6be313d76.tar.bz2
gentoo-88cb1fdfbfdc14408b5c0e847f5323e6be313d76.zip
dev-python/patsy: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/patsy')
-rw-r--r--dev-python/patsy/patsy-0.5.1.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/dev-python/patsy/patsy-0.5.1.ebuild b/dev-python/patsy/patsy-0.5.1.ebuild
index 7ae07545ef43..55fef3e05212 100644
--- a/dev-python/patsy/patsy-0.5.1.ebuild
+++ b/dev-python/patsy/patsy-0.5.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -13,33 +13,27 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
+IUSE="doc"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
+ "
+BDEPEND="
doc? (
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ )"
+
+distutils_enable_tests nose
python_compile_all() {
use doc && emake -C doc html
}
-python_test() {
- cd "${BUILD_DIR}" || die
- nosetests -v || die "Testing failed with ${EPYTHON}"
-}
-
python_install_all() {
use doc && HTML_DOCS=( doc/_build/html/. )
distutils-r1_python_install_all