summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-20 04:18:34 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-20 04:50:12 +0200
commitef8b9c91bc333405a56e38871bd1ade96aaffcca (patch)
treeec9bf992cd8fd4e2d14f41d95fe69ba8d68d0652 /dev-python/pbr
parentdev-python/sphinxcontrib-spelling: Bump to 7.0.0 (diff)
downloadgentoo-ef8b9c91bc333405a56e38871bd1ade96aaffcca.tar.gz
gentoo-ef8b9c91bc333405a56e38871bd1ade96aaffcca.tar.bz2
gentoo-ef8b9c91bc333405a56e38871bd1ade96aaffcca.zip
dev-python/pbr: Bump to 5.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-5.5.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 538bb08d5c54..5166d310d089 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,2 +1,3 @@
DIST pbr-5.4.5.tar.gz 120510 BLAKE2B f0f22a25e41820a0848aface6c241e38d8c4500d14ac3c8abf3d3b5f3f2d88680505d43f045589d700e9c07ade1643712274b156832246ca3f2050f44e4cda26 SHA512 b53ca10b7af7e365ff99ecf11942d3f047112d69f7e963716d07bc156077b08d79bb708bb93aae342e5e03c83278507b6990137dc34d0ebc11de53bd57ab3654
DIST pbr-5.5.0.tar.gz 117967 BLAKE2B cc3f023493150f0687ede07ccadc3abfb4a8dc5e0cdc0f9fd946d3a28fe2cf496683f37f934a5555875b5ac0546a0c0ed99e1bc2f7be53b47ec68d64d27cb78a SHA512 ce187787d5a51700d854790b329274aafd7d4f9e724b1b69b5ea8684cdc58c738274d30fd85bb890671bb77f2c7c88ccb488ea11df7ae9fd0505b4dc29292889
+DIST pbr-5.5.1.tar.gz 117488 BLAKE2B 52deecc6107d739daec0b2d3c397285c87c63bb3d2a2abc8266feec78d43eff84f4093b9739e2bbdf47b604a1621e4ed809a689b2167e6ea673418bd27f29018 SHA512 c72c2bb8bedd7f0606880f003dffa0ed585521b698e3e986ed2913cd74303e281fbb2374cc1a00b76777c677eb2677507eed9ccaafefceee0a689cb6fa61bab6
diff --git a/dev-python/pbr/pbr-5.5.1.ebuild b/dev-python/pbr/pbr-5.5.1.ebuild
new file mode 100644
index 000000000000..09ae1032c9e7
--- /dev/null
+++ b/dev-python/pbr/pbr-5.5.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
+BDEPEND="
+ test? (
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.1.0
+ dev-vcs/git
+ )"
+PDEPEND=""
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # TODO: investigate
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ # broken on pypy3
+ # https://bugs.launchpad.net/pbr/+bug/1881479
+ sed -e 's:test_generates_c_extensions:_&:' \
+ -i pbr/tests/test_packaging.py || die
+ rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ local -x PATH=${TEST_DIR}/scripts:${PATH}
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ stestr init || die "stestr init failed under ${EPYTHON}"
+ stestr run || die "stestr run failed under ${EPYTHON}"
+}