summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2017-05-08 09:38:34 +0100
committerTony Vroon <chainsaw@gentoo.org>2017-05-08 09:38:52 +0100
commita05e0ba49f1f767a966603b315624eba6240631a (patch)
tree02fee3bd10be788efd17104e04183100f258126b /dev-python/pcapy/pcapy-0.11.1.ebuild
parentapp-misc/jq: Mask USE=test for bug 583422 (diff)
downloadgentoo-a05e0ba49f1f767a966603b315624eba6240631a.tar.gz
gentoo-a05e0ba49f1f767a966603b315624eba6240631a.tar.bz2
gentoo-a05e0ba49f1f767a966603b315624eba6240631a.zip
dev-python/pcapy: Initial commit. Ebuild by Barzog on GitHub, minor modifications based on ebuild review by David "Soap" Seifert & Manuel "mrueg" Rüger.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/pcapy/pcapy-0.11.1.ebuild')
-rw-r--r--dev-python/pcapy/pcapy-0.11.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pcapy/pcapy-0.11.1.ebuild b/dev-python/pcapy/pcapy-0.11.1.ebuild
new file mode 100644
index 000000000000..daa2e92b27fb
--- /dev/null
+++ b/dev-python/pcapy/pcapy-0.11.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python pcap extension"
+HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/pcapy"
+SRC_URI="https://github.com/CoreSecurity/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="${DEPEND}
+ net-libs/libpcap"
+
+python_test() {
+ cd "${S}/tests" || die "Unable to activate test suite"
+ "${EPYTHON}" pcapytests.py || die "Tests failed with ${EPYTHON}"
+}