summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-13 09:06:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-13 09:08:15 +0200
commit521ea854f41ead002747bbde74d6d40d7422bd90 (patch)
tree3c84fb82b9b04f82a6fccdda835907c75187a816 /dev-python/pebble/pebble-4.5.3.ebuild
parentdev-python/markdown2: Bump to 2.3.9 (diff)
downloadgentoo-521ea854f41ead002747bbde74d6d40d7422bd90.tar.gz
gentoo-521ea854f41ead002747bbde74d6d40d7422bd90.tar.bz2
gentoo-521ea854f41ead002747bbde74d6d40d7422bd90.zip
dev-python/pebble: Bump to 4.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pebble/pebble-4.5.3.ebuild')
-rw-r--r--dev-python/pebble/pebble-4.5.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pebble/pebble-4.5.3.ebuild b/dev-python/pebble/pebble-4.5.3.ebuild
new file mode 100644
index 000000000000..23b80b0f697b
--- /dev/null
+++ b/dev-python/pebble/pebble-4.5.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Threading and multiprocessing eye-candy"
+HOMEPAGE="
+ https://pypi.org/project/Pebble/
+ https://pebble.readthedocs.io/
+ https://github.com/noxdafox/pebble"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest