summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-03 05:53:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-03 06:01:15 +0200
commitbcd4963653ba164aa09685a19f313206ff691889 (patch)
tree2063ab972dc38f5d6a56b05ed77b5d11d9a6ef97 /dev-python/pecan
parentdev-python/mrcfile: Bump to 1.4.0 (diff)
downloadgentoo-bcd4963653ba164aa09685a19f313206ff691889.tar.gz
gentoo-bcd4963653ba164aa09685a19f313206ff691889.tar.bz2
gentoo-bcd4963653ba164aa09685a19f313206ff691889.zip
dev-python/pecan: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pecan')
-rw-r--r--dev-python/pecan/Manifest1
-rw-r--r--dev-python/pecan/pecan-1.4.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pecan/Manifest b/dev-python/pecan/Manifest
index 8645aa5cf0eb..9fc683f722b3 100644
--- a/dev-python/pecan/Manifest
+++ b/dev-python/pecan/Manifest
@@ -1 +1,2 @@
DIST pecan-1.4.1.tar.gz 124777 BLAKE2B c3af6ba06aa9e24f9e49ace8117480affd34dfdc889639ab34565325e7504d3c75f17003da09f9f67f91edc536bde95080dbc51170cccc50fde3ec1929c63958 SHA512 bd5ba47935e2d97677bcdc25ad4678ec63293e0000750fa3b39a2447be326dc7e1fd4cf77ac0519e1b7c6ecc7ba7c3e66d98443e78e647fba92383f048775c83
+DIST pecan-1.4.2.tar.gz 124900 BLAKE2B bf78c630605dbf020bcda830855cf19dc660c8bdbfa6d68a9739a0da7c585ec17d30525d37337867e007aa31d3329e87224cfd4e0335b14496df911457af5c82 SHA512 cea290db5b7c4664057ec326e1f9ac11d4b523e2df83a84c3b47acbce0520f248bbd33de0f66379409a4ff463b6408b587238917362572479288d36843542ab0
diff --git a/dev-python/pecan/pecan-1.4.2.ebuild b/dev-python/pecan/pecan-1.4.2.ebuild
new file mode 100644
index 000000000000..afa88af1668e
--- /dev/null
+++ b/dev-python/pecan/pecan-1.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies"
+HOMEPAGE="
+ https://github.com/pecan/pecan/
+ https://pypi.org/project/pecan/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/scripts=/d' setup.py || die
+ distutils-r1_src_prepare
+}