summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2020-04-14 19:58:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-04-25 10:48:21 +0200
commit135fd025a8a158a5af0549c8d450dc2c3f85a78a (patch)
tree9f2e41bf2f30b3f87516d88053e127c1bf0f1ed5 /dev-python/peewee/peewee-3.13.2.ebuild
parentpackage.mask: Last rite dev-python/patch (diff)
downloadgentoo-135fd025a8a158a5af0549c8d450dc2c3f85a78a.tar.gz
gentoo-135fd025a8a158a5af0549c8d450dc2c3f85a78a.tar.bz2
gentoo-135fd025a8a158a5af0549c8d450dc2c3f85a78a.zip
dev-python/peewee: Bump to 3.13.2, py3.{7,8}
Closes: https://bugs.gentoo.org/707370 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15346 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/peewee/peewee-3.13.2.ebuild')
-rw-r--r--dev-python/peewee/peewee-3.13.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/peewee/peewee-3.13.2.ebuild b/dev-python/peewee/peewee-3.13.2.ebuild
new file mode 100644
index 000000000000..691abbc9bffd
--- /dev/null
+++ b/dev-python/peewee/peewee-3.13.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}