summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-20 08:10:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-20 08:22:50 +0100
commit049c6d6d633e6cfdd6c2e99ffac336d04aff42df (patch)
treef469b4ea50a75068741cd699248bfc797d640aee /dev-python/peewee/peewee-3.14.4.ebuild
parentdev-python/sqlalchemy: Bump to 1.4.2 (diff)
downloadgentoo-049c6d6d633e6cfdd6c2e99ffac336d04aff42df.tar.gz
gentoo-049c6d6d633e6cfdd6c2e99ffac336d04aff42df.tar.bz2
gentoo-049c6d6d633e6cfdd6c2e99ffac336d04aff42df.zip
dev-python/peewee: Bump to 3.14.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/peewee/peewee-3.14.4.ebuild')
-rw-r--r--dev-python/peewee/peewee-3.14.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/peewee/peewee-3.14.4.ebuild b/dev-python/peewee/peewee-3.14.4.ebuild
new file mode 100644
index 000000000000..618fc5042135
--- /dev/null
+++ b/dev-python/peewee/peewee-3.14.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/psycopg[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" ./runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}