summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-09-16 18:05:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2017-09-16 18:05:57 +0000
commitd3b9b22b25710af7e12d6eb810ce23fc9406a116 (patch)
treef7ea079fcbc241b34c985df0f6f43a07dd1bae2e /dev-python/peewee
parentnet-libs/libnsl: add basic multilib support (diff)
downloadgentoo-d3b9b22b25710af7e12d6eb810ce23fc9406a116.tar.gz
gentoo-d3b9b22b25710af7e12d6eb810ce23fc9406a116.tar.bz2
gentoo-d3b9b22b25710af7e12d6eb810ce23fc9406a116.zip
dev-python/peewee: Bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-2.8.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index fefd79d07fc0..9ade043b9ccd 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1,2 +1,3 @@
DIST peewee-2.7.4.tar.gz 608818 SHA256 ff25784ab40d58d659bc8f24e07fe891579b09f74417fca9d8d57772e514c409 SHA512 c72391316c8bd1f712bcb26d4d6e5ef386a415da536d78cade35d42bbb9c8c6d7b0494bf329bd67e3ac5b91a2d76e97365376b0e91a5c6a5b78ab1696f7576cb WHIRLPOOL acc0862963256173b7e918f5456e10dcfb2e533a9cf213841bb42d2bbcea475f8bf329f4227311163de5e9974ea06d1ab9d78b1ab25ce762c11f1d6689556196
DIST peewee-2.8.1.tar.gz 628870 SHA256 a14cfd248c837987346bada53617d7c298a2bd24e18fb4020e6d6e75bf5df05c SHA512 fd65001f6227f3b470046794f306def4a69b2637d916d4d7ee1057dab5671eaae88f32fe5345e3266829651e7529c53d9928516135af520832f34bfc0b1b9f39 WHIRLPOOL e95f14b16dd134153e4d5180a20546dfca3334c9db1e170b20d7f7c8b5e12331612f96daca7de2eddc0ffd64fe786db40b3482200fcd3268f2e1d407bd65fb72
+DIST peewee-2.8.2.tar.gz 762456 SHA256 f9a62c41b0e38854e420881d316fc5834b1a1900d3d8c97bc3d00cafde22c265 SHA512 8ffab1c6ac8815e409df67eb2a71604a6e1087693b848a0e49dfd7c1c1cdab4271a81cfb5a8b4c363e19c750ec65608dd6f519a1d2e9a84786d47483cd1e8e20 WHIRLPOOL df129ea2009356d34683f0ac54f6533ac9ba611196dcdd5028b8202461302706459e48b222182d9dfa7b91611d625079531672683aebf3e7d258d2e61cbb3fc0
diff --git a/dev-python/peewee/peewee-2.8.2.ebuild b/dev-python/peewee/peewee-2.8.2.ebuild
new file mode 100644
index 000000000000..453831768e06
--- /dev/null
+++ b/dev-python/peewee/peewee-2.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -i -e "s#test_suite='tests',##g;" ./setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Testsuite run using runtests.py does not require deps listed in previous ebuild
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}