summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-04-14 22:23:31 -0400
committerMike Gilbert <floppym@gentoo.org>2020-04-14 22:23:31 -0400
commita094582d244bad3a87c2edb7effc0f528ca20466 (patch)
tree16ceac2629c2a10c9f18e974992561efe754e1ab /dev-python/pexpect
parentapp-crypt/rotix: bump EAPI=7 (diff)
downloadgentoo-a094582d244bad3a87c2edb7effc0f528ca20466.tar.gz
gentoo-a094582d244bad3a87c2edb7effc0f528ca20466.tar.bz2
gentoo-a094582d244bad3a87c2edb7effc0f528ca20466.zip
dev-python/pexpect: fix build with python2 disabled
Fixes: 6df79dfa10bd801c99c1698f81701f9ae0aa31d9 Bug: https://bugs.gentoo.org/703100 Package-Manager: Portage-2.3.99, Repoman-2.3.22_p29 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/pexpect-4.8.0.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pexpect/pexpect-4.8.0.ebuild b/dev-python/pexpect/pexpect-4.8.0.ebuild
index 3de5f455d3b3..076cdb78ac2c 100644
--- a/dev-python/pexpect/pexpect-4.8.0.ebuild
+++ b/dev-python/pexpect/pexpect-4.8.0.ebuild
@@ -31,6 +31,14 @@ python_compile_all() {
use doc && emake -C doc html
}
+python_install() {
+ distutils-r1_python_install
+ if ! python_is_python3; then
+ # https://bugs.gentoo.org/703100
+ rm "${D}$(python_get_sitedir)/pexpect/_async.py" || die
+ fi
+}
+
python_install_all() {
use doc && local HTML_DOCS=( doc/_build/html/. )
if use examples; then
@@ -38,8 +46,4 @@ python_install_all() {
docompress -x /usr/share/doc/${PF}/examples
fi
distutils-r1_python_install_all
-
- # Address byte-compile QA warning, see https://bugs.gentoo.org/703100
- python_setup -2
- rm "${D}$(python_get_sitedir)"/pexpect/_async.py || die
}