summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Cerisara <andreacerisara@gmail.com>2020-09-04 07:26:18 +1000
committerJoonas Niilola <juippis@gentoo.org>2020-09-30 10:54:01 +0300
commit5d889cccc4e2ea1e0a4ab96af8f66790fefaf259 (patch)
tree7b7b23577084774110153b91064290fc4d545b0f /dev-python/pgspecial
parentmedia-gfx/gnofract4d: update HOMEPAGE and desktop mimeinfo cache (diff)
downloadgentoo-5d889cccc4e2ea1e0a4ab96af8f66790fefaf259.tar.gz
gentoo-5d889cccc4e2ea1e0a4ab96af8f66790fefaf259.tar.bz2
gentoo-5d889cccc4e2ea1e0a4ab96af8f66790fefaf259.zip
dev-python/pgspecial-1.11.10: version bump
Signed-off-by: Andrea Cerisara <andreacerisara@gmail.com> Bug: https://bugs.gentoo.org/739652 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Closes: https://github.com/gentoo/gentoo/pull/17405 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/metadata.xml13
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.10.ebuild24
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 4da6ac0294cb..de95da9f449f 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1 +1,2 @@
+DIST pgspecial-1.11.10.tar.gz 45560 BLAKE2B f4554eb812fadad984f746e8035a7a91f22480321df920bd15b96239c571c13cdf397ea38ea122f0a73167924a902955a1eb50dc865ba1e4445324358c3e3cef SHA512 452f217055873d3d1acff6b9b5016a3e721bffd4349aaa975aefe3ae1e25ca576f90eab13e7f913ebbfb796ac7b81dd8ed63c8e6d055c2ad7f8fd9d72ca8c21a
DIST pgspecial-1.11.9.tar.gz 45009 BLAKE2B 3ae53d4225d448c3291d6701caf7388023d140678461a5811673c7cc7ed242fb0c18ea38427210366f58f1886894def348051469c23aff20be7abc5e5c96622f SHA512 b07083ed715a6ac3d1b32ac954b83852fcb154f4b2757fae91ce7c35524576fa8caef5cb7201d313eac783bc956ea89c9d68f099a11c332486d677dfb185caca
diff --git a/dev-python/pgspecial/metadata.xml b/dev-python/pgspecial/metadata.xml
index 7afccfdce85b..aa7641b8040d 100644
--- a/dev-python/pgspecial/metadata.xml
+++ b/dev-python/pgspecial/metadata.xml
@@ -1,7 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>andreacerisara@gmail.com</email>
+ <name>Andrea Cerisara</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ PGSpecial provides an API to execute meta-commands
+ (AKA "special", or "backslash commands") on PostgreSQL.
+ </longdescription>
<upstream>
<remote-id type="github">dbcli/pgspecial</remote-id>
</upstream>
diff --git a/dev-python/pgspecial/pgspecial-1.11.10.ebuild b/dev-python/pgspecial/pgspecial-1.11.10.ebuild
new file mode 100644
index 000000000000..c35d1714c4d3
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.11.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+DOCS=( License.txt README.rst changelog.rst )