summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Linder <linder.gabriel@gmail.com>2019-03-15 21:31:52 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-04-09 14:52:20 +0200
commit825384b761a664272eab3e467f7f6bc17ea0841b (patch)
treec13e04116303a341dfb496a2f9146fe932c3b68d /dev-python/pgspecial
parentnet-dns/bind-tools: hppa stable wrt bug #678544 (diff)
downloadgentoo-825384b761a664272eab3e467f7f6bc17ea0841b.tar.gz
gentoo-825384b761a664272eab3e467f7f6bc17ea0841b.tar.bz2
gentoo-825384b761a664272eab3e467f7f6bc17ea0841b.zip
dev-db/pgcli: new package.
Pgcli is an enhanced command line interface for Postgres, with auto-completion and syntax highlighting. Signed-off-by: Gabriel Linder <linder.gabriel@gmail.com> Package-Manager: Portage-2.3.62, Repoman-2.3.12 Closes: https://github.com/gentoo/gentoo/pull/11378 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/metadata.xml15
-rw-r--r--dev-python/pgspecial/pgspecial-1.11.5.ebuild21
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
new file mode 100644
index 000000000000..db2a65c02605
--- /dev/null
+++ b/dev-python/pgspecial/Manifest
@@ -0,0 +1 @@
+DIST pgspecial-1.11.5.tar.gz 43649 BLAKE2B f9b8956cfcd81bba946e0323d584668c82e6fc18a0aa08012c3236636d0ad801f10f786b71707daadafc1274d5733adecf9233871b13bded8fe8e8f41fad0fc9 SHA512 984a09a10a705d91d9b97142eb2502b44b2a79d95cc1ed8596dd2f7f31515028f4c34cc54383d762a73fdefd6e59418f677b020181740b82cebb5d8e77bbc234
diff --git a/dev-python/pgspecial/metadata.xml b/dev-python/pgspecial/metadata.xml
new file mode 100644
index 000000000000..97b02e367775
--- /dev/null
+++ b/dev-python/pgspecial/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>linder.gabriel@gmail.com</email>
+ <name>Gabriel Linder</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dbcli/pgspecial</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pgspecial/pgspecial-1.11.5.ebuild b/dev-python/pgspecial/pgspecial-1.11.5.ebuild
new file mode 100644
index 000000000000..e147eeaeb5b7
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.11.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of postgres meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.1.19[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"