summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-13 08:53:18 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-13 09:14:43 +0100
commita247202a2aac5d73f394b82c60ae6015709466cb (patch)
tree545f5613cf50ee4eade72645b2c28764cad4e9af /dev-python/pgspecial
parentdev-ruby/rails: add 5.2.4.5 (diff)
downloadgentoo-a247202a2aac5d73f394b82c60ae6015709466cb.tar.gz
gentoo-a247202a2aac5d73f394b82c60ae6015709466cb.tar.bz2
gentoo-a247202a2aac5d73f394b82c60ae6015709466cb.zip
dev-python/pgspecial: Bump to 1.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/pgspecial-1.12.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 456cc942229c..d3991fe7daa1 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1 +1,2 @@
DIST pgspecial-1.11.10.tar.gz 45560 BLAKE2B f4554eb812fadad984f746e8035a7a91f22480321df920bd15b96239c571c13cdf397ea38ea122f0a73167924a902955a1eb50dc865ba1e4445324358c3e3cef SHA512 452f217055873d3d1acff6b9b5016a3e721bffd4349aaa975aefe3ae1e25ca576f90eab13e7f913ebbfb796ac7b81dd8ed63c8e6d055c2ad7f8fd9d72ca8c21a
+DIST pgspecial-1.12.1.tar.gz 47945 BLAKE2B e189695a3689f76f6fd3afc3b5f7c412dfc0a79fcd2465f8bca29b81de1609e045f0237fcc6b63a75c7df1d9a31d4c04cd8fa227493d6cce4cd6863a4c36cd2a SHA512 d1ef6462ab3d1cf5fe35f0dabc61698d7c2cf7e35b292c3cb540cce4bd613485d7dca53fd549a134209461c31c8144d72d1af1ee8aad5569766d9387b7e10e0b
diff --git a/dev-python/pgspecial/pgspecial-1.12.1.ebuild b/dev-python/pgspecial/pgspecial-1.12.1.ebuild
new file mode 100644
index 000000000000..f83f61db75dc
--- /dev/null
+++ b/dev-python/pgspecial/pgspecial-1.12.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of PostgreSQL meta commands"
+HOMEPAGE="https://github.com/dbcli/pgspecial"
+SRC_URI="https://github.com/dbcli/pgspecial/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-4.1[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.7.4[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+DOCS=( License.txt README.rst changelog.rst )